The GNU Image Manipulation Program (GIMP)

Configuring input devices dialog hangs after user input

Reported by Mark Florian on 2006-12-20
8
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned
The Gimp
Fix Released
Undecided
Unassigned
gimp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gimp

To reproduce:
1. Have graphics tablet connected and working (see below for more details)
2. Start GIMP
3. Go to File -> Preferences -> Input Devices -> Configure Extended Input Devices...
4. Observe input dialog, showing device confuration, apparently in working order
5. Change the Device drop down to something other than what's select by default
6. See that tab pane below isn't drawn and therefore can't be used.

I don't know how useful this is, but here's what GIMP puts in ~/.xsession-errors when the above is carried out:

(gimp:4745): Gtk-CRITICAL **: gtk_scrolled_window_add: assertion `bin->child == NULL' failed

(gimp:4745): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

(gimp:4745): Gdk-CRITICAL **: gdk_drawable_get_colormap: assertion `GDK_IS_DRAWABLE (drawable)' failed

(gimp:4745): Gdk-CRITICAL **: gdk_window_set_background: assertion `GDK_IS_WINDOW (window)' failed

(gimp:4745): Gtk-CRITICAL **: gtk_scrolled_window_add: assertion `bin->child == NULL' failed

(gimp:4745): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

(gimp:4745): Gdk-CRITICAL **: gdk_drawable_get_colormap: assertion `GDK_IS_DRAWABLE (drawable)' failed

(gimp:4745): Gdk-CRITICAL **: gdk_window_set_background: assertion `GDK_IS_WINDOW (window)' failed

Now, I have a Wacom Graphire 2 USB tablet, running on edgy with up-to-date *-generic kernel.

Mark Florian (markrian) wrote :

Inkscape shows almost identical behaviour to GIMP in this way. Is this then a GTK bug? Or should I file a similar bug for Inkscape?

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Probably an upstream bug, I've no input device to try. Opening an upstream task, should be forwarded upstream. What version of Ubuntu do you use?

Changed in gimp:
importance: Undecided → Low
Mark Florian (markrian) wrote :

Ubuntu 6.10, edgy

I can confirm this bug with Ubuntu 7.04 Feisty Beta

The same bug appears in inkscape who shares the same device configuration form.

Rolf Steinort (rolf-steinort) wrote :

I can confirm this for Feisty Fawn 7.04 both in gimp and inkscape.

Rolf

Christoph Langner (chrissss) wrote :

Yep, i can confirm this too. I've got a Wacom CTE-440.

GFD (gfd-deactivatedaccount) wrote :

I confirm in Feisty with a Graphire 3 and a Graphire 4 Wacom

marcus (marcus-sibbles) wrote :

Feisty with Graphire 3 here. Hoping for a fix in Gutsy!

Christoph Langner (chrissss) wrote :

The selection of "Extended Input Devices" works now fine in gutsy. The problem is solved in Inscape and Gimp.

Changed in gimp:
status: New → Fix Released
status: New → Fix Released
Changed in inkscape:
status: New → Fix Released

The problem results solved for me too on Gutsy tribe 5 with a wacom volito tablet.
Works well in Gimp and Inkscape. Good Work! thanks at all.

A virtual beer please for the bug fixers!

Thank You!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments