NVME drives do not show up in disk information

Bug #1841750 reported by Hamish McIntyre-Bhatty on 2019-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DDRescue-GUI
High
Hamish McIntyre-Bhatty
GetDevInfo
High
Hamish McIntyre-Bhatty
WxFixBoot
High
Hamish McIntyre-Bhatty

Bug Description

Due to a bug in the HardWare Lister (lshw), which can be found here: https://bugzilla.redhat.com/show_bug.cgi?id=1695343. NVME drives are currently not detected by GetDevInfo, and do not show up in the "Disk Information" window of programs that use GetDevInfo.

Unfortunately I was only recently made aware of this issue, as I don't currently have a system which can use NVME drives.

I aim to fix this soon, but this will only be a partial fix until this is fully fixed in lshw. It should nevertheless be enough to use the programs with NVME drives.

Changed in ddrescue-gui:
status: New → Triaged
Changed in wxfixboot:
status: New → Triaged
Changed in ddrescue-gui:
importance: Undecided → High
Changed in wxfixboot:
importance: Undecided → High
Changed in ddrescue-gui:
milestone: none → 2.0.2
Changed in wxfixboot:
milestone: none → 3.0.0
Changed in ddrescue-gui:
assignee: nobody → Hamish McIntyre-Bhatty (hamishmb)
Changed in wxfixboot:
assignee: nobody → Hamish McIntyre-Bhatty (hamishmb)
Changed in getdevinfo:
status: Triaged → In Progress
Changed in wxfixboot:
status: Triaged → In Progress
Changed in ddrescue-gui:
status: Triaged → In Progress

Fixed in GetDevInfo version 1.0.6.

Changed in getdevinfo:
status: In Progress → Fix Released
milestone: 1.0.5 → 1.0.6
Changed in ddrescue-gui:
status: In Progress → Fix Released
Changed in wxfixboot:
status: In Progress → Triaged

This is partially fixed for WxFixBoot now, as a result of the new GetDevInfo release, 1.0.6.

However, operating systems that reside on NVME disks may not be detected reliably on WxFixBoot currently. I'm investigating the cause of this bug and aim to produce a fix soon.

Changed in wxfixboot:
milestone: 3.0.0 → 3.0.1

Confirmed that this causes problems in WxFixBoot - EFI partition detection is broken on NVME disks because of this bug.

I will fix and release a new version of GetDevInfo soon to fix this issue.

Fixed in WxFixBoot 3.0.2

Changed in wxfixboot:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers