LUKS Encryption not supported: Stuck at getting new disk information

Bug #1665920 reported by noah on 2017-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DDRescue-GUI
Wishlist
Hamish McIntyre-Bhatty
GetDevInfo
Wishlist
Hamish McIntyre-Bhatty
WxFixBoot
Wishlist
Hamish McIntyre-Bhatty

Bug Description

I get stuck at "Getting new Disk Information"

I think I have narrowed the reason down, running getdevinfo.py yields->

18/02/2017 02:00:47 PM - root - INFO: Running on Linux: True
18/02/2017 02:00:47 PM - root - INFO: GetDevInfo: Main().GetInfo(): Preparing to get Disk info...
18/02/2017 02:00:47 PM - root - DEBUG: GetDevInfo: Main().GetInfo(): Running 'LC_ALL=C lshw -sanitize -class disk -class volume -xml'...
18/02/2017 02:00:48 PM - root - DEBUG: GetDevInfo: Main().GetInfo(): Done.
18/02/2017 02:00:48 PM - root - DEBUG: GetDevInfo: Main().GetInfo(): Running 'LC_ALL=C lvdisplay --maps'...
18/02/2017 02:00:48 PM - root - DEBUG: GetDevInfo: Main().GetInfo(): Done!
Traceback (most recent call last):
  File "/usr/share/ddrescue-gui/GetDevInfo/getdevinfo.py", line 522, in <module>
    Main().GetInfo(Standalone=True)
  File "/usr/share/ddrescue-gui/GetDevInfo/getdevinfo.py", line 341, in GetInfo
    self.ParseLVMOutput()
  File "/usr/share/ddrescue-gui/GetDevInfo/getdevinfo.py", line 243, in ParseLVMOutput
    self.AssembleLVMDiskInfo(LineCounter)
  File "/usr/share/ddrescue-gui/GetDevInfo/getdevinfo.py", line 278, in AssembleLVMDiskInfo
    DiskInfo[Volume]["HostDevice"] = DiskInfo[DiskInfo[Volume]["HostPartition"]]["HostDevice"]
KeyError: u'/dev/mapper/sda3_crypt'

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Is that the cause of the problem /dev/mapper/sda3_crypt?

lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

python --version:

Python 2.7.12

Hi,

Thanks for the bug report, and also for giving me the relevant section of log messages :)

Sounds a bit odd, could you give me the output of "lvdisplay --maps" please?

Changed in ddrescue-gui:
assignee: nobody → Hamish McIntyre-Bhatty (hamishmb)
status: New → Incomplete

Oh! Which version of DDRescue-GUI are you running?

noah (nmanpkr) wrote :

I can't believe I forgot to type the version number:p.

V: 1.6.1

  --- Logical volume ---
  LV Path /dev/ubuntu-vg/root
  LV Name root
  VG Name ubuntu-vg
  LV UUID ej45Fe-sP87-dntN-IP57-IJOr-WwIL-bw133c
  LV Write Access read/write
  LV Creation host, time ubuntu, 2017-01-25 20:51:08 -0500
  LV Status available
  # open 1
  LV Size 457.58 GiB
  Current LE 117140
  Segments 1
  Allocation inherit
  Read ahead sectors auto
  - currently set to 256
  Block device 252:1

  --- Segments ---
  Logical extents 0 to 117139:
    Type linear
    Physical volume /dev/mapper/sda3_crypt
    Physical extents 0 to 117139

  --- Logical volume ---
  LV Path /dev/ubuntu-vg/swap_1
  LV Name swap_1
  VG Name ubuntu-vg
  LV UUID zMttz7-oo9i-VTeS-wSyv-HEIb-Tap6-ItOsnZ
  LV Write Access read/write
  LV Creation host, time ubuntu, 2017-01-25 20:51:08 -0500
  LV Status available
  # open 1
  LV Size 7.20 GiB
  Current LE 1843
  Segments 1
  Allocation inherit
  Read ahead sectors auto
  - currently set to 256
  Block device 252:2

  --- Segments ---
  Logical extents 0 to 1842:
    Type linear
    Physical volume /dev/mapper/sda3_crypt
    Physical extents 117140 to 118982

Thanks!

Okay, is /dev/mapper/sda3_crypt and encrypted volume? If so, my apologies, because the current version of DDRescue-GUI won't work if you have encrypted volumes, but now that I'm aware of the issue, I shall fix it in the next release :)

Hamish

Changed in ddrescue-gui:
milestone: none → 1.6.1
importance: Undecided → Medium
importance: Medium → High

^ If so, could you tell me what encryption system this is, because it doesn't look like LUKS to me? I understand if you don't want to say :)

Hamish

Hi,

Confirmed that LUKS encryption causes a crash. Will fix in the next version.

Hamish

Changed in ddrescue-gui:
status: Incomplete → Triaged

This will be fixed in version 1.7.1/1.8

Changed in ddrescue-gui:
importance: High → Medium
Changed in ddrescue-gui:
milestone: 1.6.1 → 1.7
summary: - Stuck at getting new disk information
+ LUKS Encryption not supported: Stuck at getting new disk information
Changed in ddrescue-gui:
milestone: 1.7 → 1.7.1
Changed in ddrescue-gui:
milestone: 1.7.1 → 1.7.2

I've marked this as wishlist - this is a missing feature.

I do plan to add it, though I can't say when, because of time constraints at the moment. I will do it though, and it should be in one of the next few releases.

Changed in ddrescue-gui:
importance: Medium → Wishlist
Changed in ddrescue-gui:
milestone: 1.7.2 → 2.0.0

NB: As of newer versions of DDRescue-GUI, this is an issue with the GetDevInfo module. It may not cause crashes anymore, but I will need to check.

Changed in ddrescue-gui:
milestone: 2.0.0 → 2.0.1
Changed in wxfixboot:
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Hamish McIntyre-Bhatty (hamishmb)
milestone: none → 2.0.4
Changed in getdevinfo:
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Hamish McIntyre-Bhatty (hamishmb)
milestone: none → 1.0.4
Changed in ddrescue-gui:
milestone: 2.0.1 → 2.0.2
Changed in getdevinfo:
milestone: 1.0.4 → 1.0.5
Changed in wxfixboot:
milestone: 2.0.4 → 3.0.0

Note: Since this bug was reported, error handling has been improved significantly both in GetDevInfo and in the dependent programs - this should not cause a crash any more.

Changed in getdevinfo:
milestone: 1.0.5 → 1.0.6

No longer causes a crash with modern GetDevInfo.

Note that LUKS volumes can still not be mounted with DDRescue-GUI, but I plan to add this soon.

I also plan to add support for them in GetDevInfo to generate nice descriptions for LUKS volumes, and to detect unlocked LUKS volumes.

Changed in ddrescue-gui:
status: Triaged → Fix Released
Changed in getdevinfo:
status: Triaged → Fix Released
Changed in wxfixboot:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers