Please update FlightGear to version 2.4.0!

Bug #829244 reported by FokkerCharlie on 2011-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Medium
Christoph Korn

Bug Description

A major new release of FG is now available, but no pre-built .deb is published. Here's the source download page:

http://www.flightgear.org/download/

It tends to take a while for the official Ubuntu repos to get the new version- I can't see it being available in 11.10. Thanks in advance for your help!

Charlie

Christoph Korn (c-korn) wrote :

Taking flightgear 2.0.0-4ubuntu1 as starting point.

Changed in getdeb.net:
assignee: nobody → Christoph Korn (c-korn)
importance: Undecided → Medium
status: New → In Progress
Christoph Korn (c-korn) wrote :

Depends on libopenscenegraph 3.0.1.

Changed in getdeb.net:
status: In Progress → Won't Fix
FokkerCharlie (charlie-andrews) wrote :

According to discussion here:

http://www.flightgear.org/forums/viewtopic.php?f=21&t=13135&p=133694#p133694

openscenegraph 2.8.x should work OK- is it worth a go?

Charlie

Christoph Korn (c-korn) wrote :

Well I tried with 2.8.1 from lucid.
Maybe 2.8.3 from natty is better.
http://packages.ubuntu.com/search?keywords=libopenscenegraph-dev&searchon=names&suite=all&section=all

Changed in getdeb.net:
status: Won't Fix → In Progress
Christoph Korn (c-korn) wrote :

Still the same compilation problem. I recompiled the simgear package on natty.

Attached is the build log.

Changed in getdeb.net:
status: In Progress → Incomplete
Christoph Korn (c-korn) wrote :
Christoph Korn (c-korn) wrote :

The symbols exported by the simgear library.

Christoph Korn (c-korn) wrote :

Missed a library. Compiling...

Changed in getdeb.net:
status: Incomplete → In Progress
Christoph Korn (c-korn) wrote :

Package has been built for natty.

Changed in getdeb.net:
status: In Progress → Fix Committed
tags: added: tested-natty.amd64
Christoph Korn (c-korn) wrote :

Published.

Thanks.

---------------
flightgear (2.4.0-1~getdeb1) natty; urgency=low

  * New upstream version (LP: #829244)

 -- Christoph Korn <email address hidden> Sat, 20 Aug 2011 13:28:48 +0200

Changed in getdeb.net:
status: Fix Committed → Fix Released

Fantastic. VMT for your work on this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers