GetDeb Software Portal

Create Package: Lince 1.1beta

Reported by Vadim Peretokin on 2008-12-29
8
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Medium
Christoph Korn
Lince
High
Fernando Tarín Morales

Bug Description

About: Lince is a bittorrent client using libtorrent to handle bittorrent protocol and gtkmm for the interface, it has been designed to be a light and full featured client.

Homepage: http://lincetorrent.sourceforge.net/

Download: https://sourceforge.net/project/showfiles.php?group_id=218431

Christoph Korn (c-korn) wrote :

Starting package creation process from scratch.

Changed in getdeb.net:
assignee: nobody → c-korn
importance: Undecided → Medium
status: New → In Progress
Christoph Korn (c-korn) wrote :
Christoph Korn (c-korn) wrote :

checking for Boost headers version >= 1.36... no

Intrepid only provides 1.34.

Changed in getdeb.net:
status: In Progress → Won't Fix
murlidhar (murlidhar) wrote :

the jaunty provides libboost 1.37 .... so it now might be highly possible that a package be created

Christoph Korn (c-korn) wrote :

Trying to build for jaunty.

Changed in getdeb.net:
status: Won't Fix → In Progress
Christoph Korn (c-korn) wrote :

/usr/include/boost/asio/read_until.hpp:23:27: error: boost/regex.hpp: No such file or directory

This file is in the libboost-regex1.35-dev package which conflicts with 1.37.

Changed in getdeb.net:
status: In Progress → Invalid
murlidhar (murlidhar) wrote :

But this has been sucessfully built from source without installing anything extra from outside the repository by me

[url=http://www.ubuntu-pics.de/bild/13300/screenshot_002_xjg9jw.png][img]http://www.ubuntu-pics.de/thumb/13300/screenshot_002_xjg9jw.png[/img][/url]

Christoph Korn (c-korn) wrote :

Recalculating dependencies.

Changed in getdeb.net:
status: Invalid → In Progress
Christoph Korn (c-korn) wrote :

You were right, I only had the wrong build dependencies.

Christoph Korn (c-korn) wrote :

Package has been built for jaunty.

Changed in getdeb.net:
status: In Progress → Fix Committed
Christoph Korn (c-korn) wrote :

I can only run lince once.

(jaunty.amd64)korn@ubuntu:~/Desktop/lince/jaunty$ lince
Exiting
(jaunty.amd64)korn@ubuntu:~/Desktop/lince/jaunty$ lince
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::out_of_range> >'
  what(): address_v4 from unsigned long
Aborted

After that I have to remove the ~/.lince directory to run it again.

Christoph Korn (c-korn) wrote :

This bug is not schroot related.

It also happens in my real system.

Christoph Korn (c-korn) wrote :

The bug is not schroot related.

It also happens with my real system.

Christoph Korn (c-korn) wrote :

This has to be fixed before it can be released.

Changed in getdeb.net:
status: Fix Committed → Incomplete
Christoph Korn (c-korn) wrote :

This bug has to be fixed first.

Sorry for the delay, I have just read the mail now :(.
Can you give me more info about the problem as I am unable to reproduce the bug (gdb trace would be useful).
Also can anyone try it with latest svn and libtorrent 0.14.3.

Christoph Korn (c-korn) wrote :

Starting from scratch.

Changed in getdeb.net:
status: Incomplete → In Progress
Christoph Korn (c-korn) on 2009-09-25
Changed in getdeb.net:
status: In Progress → Triaged
Christoph Korn (c-korn) wrote :

Here is the requested backtrace.

Sorry for the delay :)

Christoph Korn (c-korn) wrote :
Christoph Korn (c-korn) wrote :

We use the status Incomplete now when waiting for an upstream fix.

Changed in getdeb.net:
status: Triaged → Incomplete

Ok I have digging on the source code on an ubuntu based system and I have been able to reproduce the bug.
The bug itself is not in lince but in libtorrent, only happens on a 64 bit system and it will be fixed updating libtorrent-rasterbar to 0.14.3 current in ubuntu is 0.14.2.

Christoph Korn (c-korn) wrote :

Ok, so unless there is a workaround I close this bug.

It will be packaged when karmic is released because karmic ships with a more recent version of the library.

Changed in getdeb.net:
status: Incomplete → Invalid
Changed in lince:
status: New → Invalid

Hi, I have a little request. Can someone try the svn version of lince with karmic?, it would be nice to have a report that all is working.

Christoph Korn (c-korn) wrote :

It compiled fine.

But I cannot start it.

$ lince
No protocol specified

(lince:27164): Gtk-WARNING **: cannot open display: :0.0

Christoph Korn (c-korn) wrote :

Sorry, was my fault.

It runs great in karmic.

Hi since karmic is out I can make a new lince release to see if now it can be added to the repositories now.
Is that ok?

Christoph Korn (c-korn) wrote :

Sure.

Changed in getdeb.net:
status: Invalid → Confirmed

Ok. I have made a new release Lince 1.1, basically is the same version you have tried.

it can be downloaded from http://sourceforge.net/projects/lincetorrent/files/lincetorrent/Lince-1.1/lince-1.1.tar.gz/download

Changed in lince:
status: Invalid → Fix Committed
importance: Undecided → High
assignee: nobody → Fernando Tarín Morales (icemanf)
Christoph Korn (c-korn) wrote :

Taking lince 1.1~beta-1~getdeb1 as starting point.

Changed in getdeb.net:
status: Confirmed → In Progress

Using that version is highly discouraged, although it may be free of the previous bug, which may be not depending on the compiler, it has some other nasty bugs, please use lince 1.1 instead

It just means that I took the diff.gz which I already created for the beta
version. But I took the tarball of 1.1.

Fernando Tarín Morales schrieb:
> Using that version is highly discouraged, although it may be free of the
> previous bug, which may be not depending on the compiler, it has some
> other nasty bugs, please use lince 1.1 instead
>

I misunderstood that sorry.

Christoph Korn (c-korn) wrote :

Package has been built for karmic.

Changed in getdeb.net:
status: In Progress → Fix Committed
Christoph Korn (c-korn) on 2009-10-30
tags: added: tested-karmic.amd64
Christoph Korn (c-korn) wrote :

Published.

Thanks.

---------------
lince (1.1-1~getdeb1) karmic; urgency=low

  * New upstream version (LP: #312165)

 -- Christoph Korn <email address hidden> Fri, 30 Oct 2009 11:54:54 +0100

Changed in getdeb.net:
status: Fix Committed → Fix Released

lince 1.2 is out please update the deb package

Thanks in advance.

Christoph Korn (c-korn) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers