Gephi - The Open Graph Visualization Platform

Mismatch between the color given to a node using the painter and the color selected

Reported by Paul-Antoine Bittner on 2010-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Confirmed
Wishlist
Unassigned
0.7
Confirmed
Wishlist
Unassigned

Bug Description

When using the painter to color a node, the color given to the node is not the same as the color selected. It is a mix between the current color of the node and the color selected. For example, if the current color is black and the selected color is white, the node will become gray.

This behavior is nice but is not explicit. It comes from the fact that the intensity is set to 0.3 in the class Painter. I would suggest to add to the UI the possibility to select the intensity (as for the brush) or to set the intensity to 1 by default when using the painter.

description: updated
description: updated
Changed in gephi:
milestone: none → 0.7alpha4
Peter Krantz (peter-krantz) wrote :

I have noticed that if you press and hold the mouse button the node will eventually be in the selected color. In a large graph it may take several seconds before it reaches the real color.

This painter has to be improved indeed, more option and/or more explicit

Changed in gephi:
status: New → Confirmed
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers