Import fails for NET (Pajek) file with position/color data

Bug #860825 reported by Aristomenis on 2011-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Mathieu Bastian

Bug Description

On http://forum.gephi.org/viewtopic.php?f=4&t=1422 I was asked to report the following as a bug.

I am importing a file with the following structure:

*Vertices 1132
   1 "1" 0.653932 0.503459 0.5 box ic Mahogany
   2 "2" 0.675676 0.455203 0.5 box ic White
...
*Edges
1 2 1
1 3 1
...

According to http://gephi.org/users/supported-graph-formats/ , "Visualization attributes: Only GraphML, GDF and GEXF importers are able to recognize nodes position, color and size attributes. Positions in Pajek NET files are also found."

However, no graph is displayed when I import the file. There are no import errors, and I am otherwise able to manipulate the graph with standard Gephi functions.

I am running Gephi .8 alpha under OS X 10.7.1. I have attached the exact file I am attempting to import, which has ~1000 nodes and ~35000 edges.

Please let me know if you require further assistance resolving this bug.

Aristomenis (pikeas) wrote :

The position seems to be well imported but as the range of values is very small (0-1) the network is not really visible. The problem is that the size is not properly parsed so the auto scaling provess is not doing his job. We need to fix the size parsing, which come after positions.

Changed in gephi:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Mathieu Bastian (mathieu.bastian)

Fixed in rev 2479

Changed in gephi:
status: Confirmed → Fix Committed
Changed in gephi:
milestone: none → 0.8alpha
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers