NullPointerException when creating newProjects too quickly.

Bug #817170 reported by Matthew Cheung
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Medium
Mathieu Bastian

Bug Description

java.lang.NullPointerException
 at org.gephi.project.impl.ProjectControllerImpl.openWorkspace(ProjectControllerImpl.java:241)
 at org.gephi.project.impl.ProjectControllerImpl.openProject(ProjectControllerImpl.java:205)
 at org.gephi.project.impl.ProjectControllerImpl.newProject(ProjectControllerImpl.java:81)

Occurs when trying to make new Project too quickly because the disable() function in FilterControllerImpl doesn't check to see if model is already null before before calling model.getCurrentResult(). Should be easy 1 line fix.

Revision history for this message
Mathieu Bastian (mathieu.bastian) wrote :

Fixed in rev 2311. Thanks a lot for the pointer in the right direction.

Changed in gephi:
importance: Undecided → Medium
assignee: nobody → Mathieu Bastian (mathieu.bastian)
status: New → Confirmed
status: Confirmed → Fix Committed
Changed in gephi:
milestone: none → 0.8alpha
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers