Preview tab: no option to switch off node borders?

Bug #808606 reported by Axel Bruns on 2011-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Mathieu Bastian

Bug Description

Hi,

in the Preview tab, can we please get an option to switch off the drawing of node borders altogether (or to set the border colour to the colour of the node body) ? Especially when rendering graphs with a very large number of small nodes, the colour of the node borders ends up overwhelming the colour of the nodes themselves - even when the border width is set to a very small amount (e.g. 0.000001) and the node border colour is set to the colour of the background.

I'm attaching a PDF of one of my large graphs as an example: it contains 160,000+ nodes, whose colours range from pale to dark red, with node sizes corresponding to node colour. As you can see, the smaller nodes appear in black, since that's the colour of the node borders (even though the node border width is set to a very small number). You can only make out the actual colour of the smaller nodes themselves by zooming in _very_ closely.

If we could at least set the colour of the node borders to the colour of the nodes themselves (similar to setting the colours of edges to 'source' or 'target'), that would help; better yet, it would be great to be able to switch off the rendering of node borders altogether. Setting border width to 0 doesn't seem to work, by the way.

Thanks,

Axel Bruns

Axel Bruns (a-bruns) wrote :

Very good suggestions, and setting border to zero should work, seems to be a bug of the pdf exporter.

Changed in gephi:
status: New → Confirmed
importance: Undecided → Low
Axel Bruns (a-bruns) wrote :

Thanks !

This is fixed in the new preview. Borders can be zero size or the node's color. Thanks.

Changed in gephi:
status: Confirmed → Fix Committed
assignee: nobody → Mathieu Bastian (mathieu.bastian)
Axel Bruns (a-bruns) wrote :

Brilliant - thanks !

Changed in gephi:
milestone: none → 0.8alpha
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers