Resizing edge sizes changes edge weight values

Bug #803763 reported by Axel Bruns on 2011-06-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Medium
Mathieu Bastian

Bug Description

Hi,

I _think_ this is a bug: I'm working with network data where (in addition to weight), edges have a number of other attributes.

As a simplified example, my data would say that an edge from node A to node B is 30% of type X, and 70% of type Y, etc. - in other words:

source target weight type_x type_y
A B 10 0.3 0.7
C D 4 0.5 0.5

The edge dataset imports into Gephi's Data Laboratory perfectly well (with the type_x / type_y columns imported as column type 'Float', for example), and I can create a network map without problems (e.g. with standard settings using Force Atlas 2).

However, if I then try to use the Ranking tab to change the size (thickness) of the network edges so that edge size is according to the value in type_x or type_y, while the Force Atlas 2 algorithm is still running, the whole network graph changes shape.

I'm not completely sure if this is a bug or a feature. As I understand it, the changes made in the Ranking tab should be completely cosmetic, and have nothing to do with the underlying (mathematical) structure of the network itself: for example, I can set node sizes according to various metrics, but that doesn't mean that the nodes will change position and become more or less central to the network.

I _think_ the same should apply here: the positioning of the nodes in an attraction/repulsion-based network graph like Force Atlas (2) should always simply be based on the _weight_ of the edges between them, and should be independent of how (i.e. based on what data) these edges are displayed. So, two nodes with a weighty edge between them would be close together, and if I chose to display only those edges as thick which have a high score on some other metric, that should not affect the positioning of those edges relative to one another.

Or, perhaps, it would be useful to choose which edge metric (weight or something else) Gephi's algorithms use to calculate the position of nodes in the graph visualisation, independent of which metric is used to calculate the visual thickness of the edges as they are displayed ?

I hope this makes sense - happy to provide further information...

Axel Bruns

This is a severe bug because the Ranking changes the edge weight (see in Data Lab), but it should not do that.

Changed in gephi:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 0.8alpha
summary: - Resizing edge sizes changes node attraction
+ Resizing edge sizes changes edge weight values

The bug remains even after the recent Ranking refactoring.

Changed in gephi:
assignee: nobody → Mathieu Bastian (mathieu.bastian)
tags: added: ranking
removed: edge weight

Ok, althought it could make sense for some people that have several "weight" columns and use Ranking to apply different ones, its not a good thing to overwrite the weight as it can't be undone. For that use case, the user will have to use the datalab.

I can simply disable the edge size ranking.

Fixed in rev 2315

Changed in gephi:
status: Confirmed → Fix Committed
importance: Critical → Medium

Critical bugs should be reserved to systematic crashes and build problems.

Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers