Data Lab: Exception when selecting only one column for merging

Bug #785269 reported by Sébastien Heymann on 2011-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Medium
Eduardo Ramos

Bug Description

Way to reproduce:
1. Go to Data Lab > Edges
2. Select Merge Columns
3. Choose one column (i.e. weights) and the SUM operator
4. Apply

java.lang.ClassCastException: org.gephi.datalab.plugin.manipulators.columns.merge.SumNumbers cannot be cast to org.gephi.datalab.plugin.manipulators.columns.merge.GeneralColumnTitleChooser
 at org.gephi.datalab.plugin.manipulators.columns.merge.ui.GeneralColumnTitleChooserUI.setup(GeneralColumnTitleChooserUI.java:72)
 at org.gephi.datalab.api.DataLaboratoryHelper$3.run(DataLaboratoryHelper.java:204)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
 at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:148)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Changed in gephi:
importance: Undecided → Medium
assignee: nobody → Eduardo Ramos (eduramiba)
milestone: none → 0.8alpha
tags: added: datalab
Eduardo Ramos (eduramiba) wrote :

Fixed in rev 2227

It was caused because SumNumbers lacked a "implements GeneralColumnTitleChooser" so it must have never worked since that interface was added to column merge strategies.

Changed in gephi:
status: New → Fix Committed
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers