Average degree cannot be switched to directed / undirected

Bug #760454 reported by seinecle on 2011-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Undecided
Sébastien Heymann

Bug Description

To create the bug:
- in the statistics panel, select "average degree".
- in the window, select "directed" or "undirected" graph. Run the stat.
- now, reselect the "average degree" stat => bug: no window opens, the algorithm is run with the possibility to change the choice (undirected to directed graph, or the reverse).

- Note: other stat functions do not suffer from this bug (see, eg, "Av. Path Length"), so it should be possible to copy their behavior to "average degree".

It is normal because the average in-degree is equal to the average out-degree, so each of these value can be derived directly by dividing the degree by 2

avg in-degree = avg out-degree = degree / 2

What is weird is that you shouldn't have a window to let you choose...and I can't reproduce this bug.

Do you use Gephi 0.7beta or 0.8alpha?

Changed in gephi:
status: New → Incomplete

Gephi 0.8 alpha.

--------------------------------------------------
Clement Levallois, PhD
Erasmus University Rotterdam, The Netherlands
<email address hidden> | www.clementlevallois.net | Twitter: @seinecle

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Sébastien Heymann
Sent: Thursday, April 14, 2011 11:00 PM
To: <email address hidden>
Subject: [Bug 760454] Re: Average degree cannot be switched to directed / undirected

Do you use Gephi 0.7beta or 0.8alpha?

** Changed in: gephi
       Status: New => Incomplete

--
You received this bug notification because you are a direct subscriber of the bug.
https://bugs.launchpad.net/bugs/760454

Title:
  Average degree cannot be switched to directed / undirected

Status in Gephi - Network exploration and manipulation:
  Incomplete

Bug description:
  To create the bug:
  - in the statistics panel, select "average degree".
  - in the window, select "directed" or "undirected" graph. Run the stat.
  - now, reselect the "average degree" stat => bug: no window opens, the algorithm is run with the possibility to change the choice (undirected to directed graph, or the reverse).

  - Note: other stat functions do not suffer from this bug (see, eg,
  "Av. Path Length"), so it should be possible to copy their behavior to
  "average degree".

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/gephi/+bug/760454/+subscribe

Is someone else able to reproduce it?

Changed in gephi:
milestone: none → 0.8alpha
soverign (brycecr) wrote :

Seems to me like the graph density always calculates the undirected version, even if the graph is directed. That seems wrong.

That is really weird Clement, as the settings window should not appear in 0.8 anymore.

soverign -> It works fine for me, please open another bug with steps to reproduce the issue

Tore Opsahl (tore-opsahl) wrote :

Hey guys!

Thanks for a great software.

I just tried analysing the Facebook-like online social network (http://toreopsahl.com/datasets/#online_social_network; weighted by number of characters; UCINET/dl-format) in alpha-0.8. The network has 1899 nodes with 20,296 directed ties among them. The average degree in this network should be 20296/1899=10.688; however, it is reported as 21.375 (i.e., 10.688*2). It seems the switch between undirected and directed networks is not working as this would be corrected number if the network was undirected.

Best,
Tore

Thanks for notice. Fixed on rev 2360.

Changed in gephi:
status: Incomplete → Fix Committed
Changed in gephi:
assignee: nobody → Sébastien Heymann (sebastien.heymann)
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers