Ranking Color can't be changed on OSX

Bug #737727 reported by Caged on 2011-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Medium
Mathieu Bastian

Bug Description

Any attempt to change the gradient color in the ranking panel simply "refreshes" the screen and reverts the color to black and white.

Steps to reproduce on OSX:
1. Open Les Miserables.gefx
2. Open the ranking tab and choose "Degree" as the ranking parameter
3. Select a color stop from the gradient labeled Color.
4. Choose a color and press OK.

Expected Result:
The color gradient reflects the color I just chose.

Actual Result:
The screen kind of flashes and the color reverts back to the original black or white color.

Product Version: Gephi 0.7 beta
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334
System: Mac OS X version 10.6.6 running on x86_64; MacRoman; en_US (gephi07beta)
Userdir: /Users/justin/Library/Application Support/gephi07beta/dev

Caged (justin-encytemedia) wrote :

A quick update. After further investigation, this seems to affect all Gradient widgets/ui. If you choose the heatmap tool in the Graph view and attempt to change the gradient colors, the ui simply redraws and the gradient reverts back to its original color.

I have this issue randomly on the Partition colors, I'm on Windows7 and Ubuntu 8.10. So this is not plat-form related.

tags: added: macosx ranking
Changed in gephi:
assignee: nobody → Mathieu Bastian (mathieu.bastian)
milestone: none → 0.7beta
tags: added: colors partition
removed: macosx
Changed in gephi:
status: New → Confirmed
importance: Undecided → Medium

I'm able to reproduce it, possibly introduces with the last JRE update as I believe it was working before

I think I fixed the issue, but it needs further testing on other platforms.

The problem was located on the Gradient slider component, so the partition problem must be something else.

Changed in gephi:
status: Confirmed → Fix Committed

Fixed on rev 2173

Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers