Windows installer should not require admin privileges

Bug #663337 reported by p-f on 2010-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Medium
Mathieu Bastian

Bug Description

Problem: the windows installer requires admin privileges to run. A lot of users on corporate or university workstations don't have such privileges.
Installer: http://launchpad.net/gephi/0.7/0.7beta/+download/gephi-0.7-beta.setup.exe
OS: Windows XP Professional sp3
Severity: annoyance or unusable, depending on your point of view

Steps to reproduce the problem:
1) Download http://launchpad.net/gephi/0.7/0.7beta/+download/gephi-0.7-beta.setup.exe
2) Attempt to run it as a user that does not have admin privileges

Behaviour:
- Installer terminates with the error message "You must be logged in as an administrator when installing this program".

Expected behaviour:
- No error (I have write access to *some* folders on the computer - why not let me install there?)

Current workaround: compile from source

Hi, thanks for your report.

That shouldn't happen, as we are using InnoSetup which manage this very well. I'll check this out.

Changed in gephi:
milestone: none → 0.7beta
tags: added: windowsxp
tags: added: installation
Changed in gephi:
status: New → Confirmed
assignee: nobody → Mathieu Bastian (mathieu.bastian)
importance: Undecided → Medium

Thanks for reporting. The problem is solved, and the upcoming 0.8 release will have the corrected installer.

Changed in gephi:
status: Confirmed → Fix Committed
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions