Graph Window in Overview Tab Fails to Load

Bug #659773 reported by C. Brayton on 2010-10-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Sébastien Heymann

Bug Description

In the Overview tab, the graph window fails to display, although the hierarchy and data table window will load. During the loading of the application, inexplicably, a pop-up notice appears reading "File Format Not Recognized" or some such. I try running with --reload plaform/modules/* but to no avail. Error output:

Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException:
 at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
Could not find the main class: . Program will exit.
tiodude@lengalenga:~/crawls/gephi-0.7-beta$ bin/gephi* --reload /platform/modules/*
java.io.FileNotFoundException: /platform/modules/* (No such file or directory)
 at java.io.FileInputStream.open(Native Method)
 at java.io.FileInputStream.<init>(FileInputStream.java:106)
 at org.netbeans.Util.makeTempJar(Util.java:87)
 at org.netbeans.StandardModule.ensurePhysicalJar(StandardModule.java:269)
 at org.netbeans.StandardModule.loadManifest(StandardModule.java:295)
 at org.netbeans.StandardModule.<init>(StandardModule.java:136)
 at org.netbeans.ModuleFactory.create(ModuleFactory.java:69)
 at org.netbeans.ModuleManager.create(ModuleManager.java:517)
 at org.netbeans.core.startup.ModuleSystem.deployTestModule(ModuleSystem.java:357)
 at org.netbeans.core.startup.TestModuleDeployer.deployTestModule(TestModuleDeployer.java:71)
 at org.netbeans.core.startup.CLITestModuleReload.cli(CLITestModuleReload.java:80)
 at org.netbeans.CLIHandler.notifyHandlers(CLIHandler.java:230)
 at org.netbeans.CLIHandler$2.exec(CLIHandler.java:594)
 at org.netbeans.CLIHandler.finishInitialization(CLIHandler.java:412)
 at org.netbeans.MainImpl.finishInitialization(MainImpl.java:214)
 at org.netbeans.Main.finishInitialization(Main.java:87)
 at org.netbeans.core.startup.Main.start(Main.java:308)
 at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:114)
 at java.lang.Thread.run(Thread.java:619)
tiodude@lengalenga:~/crawls/gephi-0.7-beta$ bin/gephi* --reload platform/modules/*
java.io.FileNotFoundException: /home/tiodude/crawls/gephi-0.7-beta/platform/modules/ext (Is a directory)
 at java.io.FileInputStream.open(Native Method)
 at java.io.FileInputStream.<init>(FileInputStream.java:106)
 at org.netbeans.Util.makeTempJar(Util.java:87)
 at org.netbeans.StandardModule.ensurePhysicalJar(StandardModule.java:269)
 at org.netbeans.StandardModule.loadManifest(StandardModule.java:295)
 at org.netbeans.StandardModule.<init>(StandardModule.java:136)
 at org.netbeans.ModuleFactory.create(ModuleFactory.java:69)
 at org.netbeans.ModuleManager.create(ModuleManager.java:517)
 at org.netbeans.core.startup.ModuleSystem.deployTestModule(ModuleSystem.java:357)
 at org.netbeans.core.startup.TestModuleDeployer.deployTestModule(TestModuleDeployer.java:71)
 at org.netbeans.core.startup.CLITestModuleReload.cli(CLITestModuleReload.java:80)
 at org.netbeans.CLIHandler.notifyHandlers(CLIHandler.java:230)
 at org.netbeans.CLIHandler$2.exec(CLIHandler.java:594)
 at org.netbeans.CLIHandler.finishInitialization(CLIHandler.java:412)
 at org.netbeans.MainImpl.finishInitialization(MainImpl.java:214)
 at org.netbeans.Main.finishInitialization(Main.java:87)
 at org.netbeans.core.startup.Main.start(Main.java:308)
 at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:114)
 at java.lang.Thread.run(Thread.java:619)

Failing to load the graph window is probably a graphic issue. What is your system? Do you have your graphic card driver up to date?

See also http://gephi.org/users/detect-and-fix-graphical-problems/

Running "--reload plaform/modules/*" is not something you can do, if you wanna reset parameters, you can simply delete the gephi user directory (see http://wiki.gephi.org/index.php/Troubleshooting#Where_are_user_files.3F)

Download full text (4.6 KiB)

I should have provided the system info. That is a nice diagnostic page,
thanks, that should help. Gephi rox.

cb

On Wed, 2010-10-13 at 10:03 +0000, Mathieu Bastian wrote:
> Failing to load the graph window is probably a graphic issue. What is
> your system? Do you have your graphic card driver up to date?
>
> See also http://gephi.org/users/detect-and-fix-graphical-problems/
>
> Running "--reload plaform/modules/*" is not something you can do, if you
> wanna reset parameters, you can simply delete the gephi user directory
> (see
> http://wiki.gephi.org/index.php/Troubleshooting#Where_are_user_files.3F)
>
> --
> Graph Window in Overview Tab Fails to Load
> https://bugs.launchpad.net/bugs/659773
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gephi - Network exploration and manipulation: New
>
> Bug description:
> In the Overview tab, the graph window fails to display, although the hierarchy and data table window will load. During the loading of the application, inexplicably, a pop-up notice appears reading "File Format Not Recognized" or some such. I try running with --reload plaform/modules/* but to no avail. Error output:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> Caused by: java.lang.ClassNotFoundException:
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
> Could not find the main class: . Program will exit.
> tiodude@lengalenga:~/crawls/gephi-0.7-beta$ bin/gephi* --reload /platform/modules/*
> java.io.FileNotFoundException: /platform/modules/* (No such file or directory)
> at java.io.FileInputStream.open(Native Method)
> at java.io.FileInputStream.<init>(FileInputStream.java:106)
> at org.netbeans.Util.makeTempJar(Util.java:87)
> at org.netbeans.StandardModule.ensurePhysicalJar(StandardModule.java:269)
> at org.netbeans.StandardModule.loadManifest(StandardModule.java:295)
> at org.netbeans.StandardModule.<init>(StandardModule.java:136)
> at org.netbeans.ModuleFactory.create(ModuleFactory.java:69)
> at org.netbeans.ModuleManager.create(ModuleManager.java:517)
> at org.netbeans.core.startup.ModuleSystem.deployTestModule(ModuleSystem.java:357)
> at org.netbeans.core.startup.TestModuleDeployer.deployTestModule(TestModuleDeployer.java:71)
> at org.netbeans.core.startup.CLITestModuleReload.cli(CLITestModuleReload.java:80)
> at org.netbeans.CLIHandler.notifyHandlers(CLIHandler.java:230)
> at org.netbeans.CLIHandler$2.exec(CLIHandler.java:594)
> at org.netbeans.CLIHandler.finishInitialization(CLIHandler.java:412)
> at org.netbeans.MainImpl.finishInitialization(MainImpl.java:214)
> at org.netbeans.Main.finishInitialization(Main.java:87)
> at org.netbeans.core.startup.Main.start(Main.java:308)
> at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:114)
> at java.lang.Thread.run(Thread.java:619)
> tiodude@le...

Read more...

Download full text (5.2 KiB)

Still having the problem. My graphics card is

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express
Integrated Graphics Controller (rev 10)

OS is Debian 2.6.32-5-686

The driver is i915

> i915 221927 2
> drm_kms_helper 18305 1 i915
> drm 112088 3 i915,drm_kms_helper
> i2c_algo_bit 3497 1 i915
> video 14605 1 i915
> i2c_core 12696 5 i915,drm_kms_helper,drm,i2c_algo_bit,i2c_i801
> button 3598 1 i915

I had tried to enable, and then disabled, 3D acceleration (compiz,
glx).

I am totally perplexed.

cb

On Wed, 2010-10-13 at 10:03 +0000, Mathieu Bastian wrote:
> Failing to load the graph window is probably a graphic issue. What is
> your system? Do you have your graphic card driver up to date?
>
> See also http://gephi.org/users/detect-and-fix-graphical-problems/
>
> Running "--reload plaform/modules/*" is not something you can do, if you
> wanna reset parameters, you can simply delete the gephi user directory
> (see
> http://wiki.gephi.org/index.php/Troubleshooting#Where_are_user_files.3F)
>
> --
> Graph Window in Overview Tab Fails to Load
> https://bugs.launchpad.net/bugs/659773
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gephi - Network exploration and manipulation: New
>
> Bug description:
> In the Overview tab, the graph window fails to display, although the hierarchy and data table window will load. During the loading of the application, inexplicably, a pop-up notice appears reading "File Format Not Recognized" or some such. I try running with --reload plaform/modules/* but to no avail. Error output:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> Caused by: java.lang.ClassNotFoundException:
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
> Could not find the main class: . Program will exit.
> tiodude@lengalenga:~/crawls/gephi-0.7-beta$ bin/gephi* --reload /platform/modules/*
> java.io.FileNotFoundException: /platform/modules/* (No such file or directory)
> at java.io.FileInputStream.open(Native Method)
> at java.io.FileInputStream.<init>(FileInputStream.java:106)
> at org.netbeans.Util.makeTempJar(Util.java:87)
> at org.netbeans.StandardModule.ensurePhysicalJar(StandardModule.java:269)
> at org.netbeans.StandardModule.loadManifest(StandardModule.java:295)
> at org.netbeans.StandardModule.<init>(StandardModule.java:136)
> at org.netbeans.ModuleFactory.create(ModuleFactory.java:69)
> at org.netbeans.ModuleManager.create(ModuleManager.java:517)
> at org.netbeans.core.startup.ModuleSystem.deployTestModule(ModuleSystem.java:357)
> at org.netbeans.core.startup.TestModuleDeployer.deployTestModule(TestModuleDeployer.java:71)
> at org.netbeans.core.startup.CLITestModuleReload.cli(CLITestModuleReloa...

Read more...

Download full text (12.8 KiB)

The log file error message is

Method: getDefault
Class: class org.gephi.visualization.component.GraphTopComponent
Caused: javax.media.opengl.GLException: Unable to select one of the
provided GLCapabilities
at
javax.media.opengl.DefaultGLCapabilitiesChooser.chooseCapabilities(DefaultGLCapabilitiesChooser.java:218)
at
com.sun.opengl.impl.x11.X11GLDrawableFactory.chooseGraphicsConfiguration(X11GLDrawableFactory.java:190)
at
javax.media.opengl.GLCanvas.chooseGraphicsConfiguration(GLCanvas.java:520)
at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:131)
at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:90)
at org.gephi.visualization.swing.GraphCanvas.<init>(GraphCanvas.java:49)
at
org.gephi.visualization.config.VizCommander.createCanvas(VizCommander.java:33)
at
org.gephi.visualization.VizController.initInstances(VizController.java:113)
at
org.gephi.visualization.VizController.getInstance(VizController.java:69)
at
org.gephi.visualization.component.GraphTopComponent.<init>(GraphTopComponent.java:62)
at
org.gephi.visualization.component.GraphTopComponent.getDefault(GraphTopComponent.java:210)
Caused: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.netbeans.modules.settings.convertors.XMLSettingsSupport
$SettingsRecognizer.createFromMethod(XMLSettingsSupport.java:673)
Caused: java.io.IOException: Error reading
MultiFileObject@1af78ce[Windows2Local/Components/GraphTopComponent.settings]
at org.netbeans.modules.settings.convertors.XMLSettingsSupport
$SettingsRecognizer.createFromMethod(XMLSettingsSupport.java:681)
at org.netbeans.modules.settings.convertors.XMLSettingsSupport
$SettingsRecognizer.instanceCreate(XMLSettingsSupport.java:584)
at org.netbeans.modules.settings.convertors.SerialDataConvertor
$SettingsInstance.instanceCreate(SerialDataConvertor.java:423)
at
org.netbeans.core.windows.persistence.PersistenceManager.getTopComponentPersistentForID(PersistenceManager.java:533)
at
org.netbeans.core.windows.persistence.PersistenceManager.getTopComponentForID(PersistenceManager.java:643)
at
org.netbeans.core.windows.PersistenceHandler.getTopComponentForID(PersistenceHandler.java:460)
at
org.netbeans.core.windows.PersistenceHandler.initModeFromConfig(PersistenceHandler.java:421)
at
org.netbeans.core.windows.PersistenceHandler.load(PersistenceHandler.java:206)
at
org.netbeans.core.windows.WindowSystemImpl.load(WindowSystemImpl.java:73)
at org.netbeans.core.GuiRunLevel$2.run(GuiRunLevel.java:181)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:137)
at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDi...

Changed in gephi:
milestone: none → 0.7beta
tags: added: opengl

Fix on rev 2134

However it will just handle the exception. The rendering engine will work without double buffering, hardware acceleration nor antialiasing...but it should still be alive :)

Changed in gephi:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Sébastien Heymann (sebastien.heymann)

I doubt that will work with JOGL

Changed in gephi:
status: Fix Committed → Fix Released
AL (y4gr5rzn) wrote :

This bug appeared in 0.8-alpha with latest updates...
Debian x86-32, intel video.

java.lang.IllegalArgumentException: GLDrawableFactory.chooseGraphicsConfiguration() was not used when creating this Component
    at com.sun.opengl.impl.x11.X11GLDrawableFactory.getGLDrawable(X11GLDrawableFactory.java:238)
    at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:142)
    at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:90)
    at org.gephi.visualization.swing.GraphCanvas.<init>(GraphCanvas.java:49)
    at org.gephi.visualization.config.VizCommander.createCanvas(VizCommander.java:33)
    at org.gephi.visualization.VizController.initInstances(VizController.java:113)
...

AL (y4gr5rzn) wrote :

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers