Installation on Mac OS X v 10.5.8

Bug #620905 reported by Bénédicte BATRANCOURT on 2010-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
High
Mathieu Bastian
0.7
Fix Released
High
Unassigned

Bug Description

Hello,
I've installed Gephi-0.7 on a Mac OS X v 10.5.8.
When I run the software I only obtain a short menu: GephiDesktop and no other functions.
I can correctly used this same software on my PC Windows.
I thank you by advance
Best resgards
Bénédicte B.

Hello, do you have Java6 enabled on the computer? That could be the reason, see http://gephi.org/users/install-java-6-mac-os-x-leopard/

  Hello, Yes, I've seen the notice about Java6 and it's the version
installed and enabled on my computer.
Thank
Bénédicte

Le 20/08/10 09:33, Mathieu Bastian a écrit :
> Hello, do you have Java6 enabled on the computer? That could be the
> reason, see http://gephi.org/users/install-java-6-mac-os-x-leopard/
>

f you go to a terminal and do "java -version" is it Java6? Sometimes some environment variable could set Java5 instead of Java6 as default even if the settings are set on Java6.

thanks,
I'm going on the terminal and I've obtained the following information:

Last login: Mon Aug 23 18:57:43 on console
new-host:~ BBatrancourt$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-9M3165)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)
new-host:~ BBatrancourt$

ok, that seems fine...

Could you try to locate and copy-paste the content of the log file. The path of the file is indicated here http://wiki.gephi.org/index.php/HowTo_report_a_bug

Download full text (85.5 KiB)

Thanks, this is the following log:

-------------------------------------------------------------------------------
>Log Session: Friday, August 27, 2010 2:57:40 PM CEST
>System Info:
  Product Version = Gephi 0.7 alpha4 200912041610
  Operating System = Mac OS X version 10.5.8 running on x86_64
  Java; VM; Vendor = 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279; Apple Inc.
  Runtime = Java(TM) SE Runtime Environment 1.6.0_20-b02-279-9M3165
  Java Home = /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
  System Locale; Encoding = fr_FR (gephidesktop); MacRoman
  Home Directory = /Users/BBatrancourt
  Current Directory = /
  User Directory = /Users/BBatrancourt/Library/Application Support/gephidesktop/dev
  Installation = /Applications/gephi-0.7-alpha4.app/Contents/Resources/gephidesktop/gephidesktop
                            /Applications/gephi-0.7-alpha4.app/Contents/Resources/gephidesktop/platform11
  Boot & Ext. Classpath = /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jsfd.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/classes.jar:/System/Library/Frameworks/JavaVM.framework/Frameworks/JavaRuntimeSupport.framework/Resources/Java/JavaRuntimeSupport.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/ui.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/laf.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/sunrsasign.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jsse.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jce.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/charsets.jar:/Library/Java/Extensions/gluegen-rt.jar:/Library/Java/Extensions/j3dcore.jar:/Library/Java/Extensions/j3dutils.jar:/Library/Java/Extensions/jhdf5.jar:/Library/Java/Extensions/jhdf5obj.jar:/Library/Java/Extensions/jhdfobj.jar:/Library/Java/Extensions/jmf.jar:/Library/Java/Extensions/jogl.jar:/Library/Java/Extensions/vecmath.jar:/System/Library/Java/Extensions/AppleScriptEngine.jar:/System/Library/Java/Extensions/CoreAudio.jar:/System/Library/Java/Extensions/dns_sd.jar:/System/Library/Java/Extensions/j3daudio.jar:/System/Library/Java/Extensions/j3dcore.jar:/System/Library/Java/Extensions/j3dutils.jar:/System/Library/Java/Extensions/jai_codec.jar:/System/Library/Java/Extensions/jai_core.jar:/System/Library/Java/Extensions/mlibwrapper_jai.jar:/System/Library/Java/Extensions/MRJToolkit.jar:/System/Library/Java/Extensions/QTJava.zip:/System/Library/Java/Extensions/vecmath.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext/apple_provider.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext/dnsns.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext/localedata.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext/sunjce_provider.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext/sunpkcs11.jar
  Application Classpath = /Applications/gephi-0.7-alpha4.app/Contents/Resources...

Thanks, that helps a lot. I can see the initialization somehow goes wrong on your computer and comes to infinite loop.

I think I found the problem and just corrected it. The fix will be available in the 0.7beta version which is coming in a cuple of days. As I'm not sure if my fix corrects the problem, let me know when you test the 0.7beta if the bug remains.

Changed in gephi:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Mathieu Bastian (mathieu.bastian)
milestone: none → 0.7alpha4
status: Confirmed → Fix Committed

Thanks, I wait the fix and I will test and report to you the result

Hi,
I have read the different messages on this page but I'm not sure of the signification. Is the Gephi 0.7alpha4 the new version ? I've installed it again but I have the same problem on my Mac.
Thanks by advance
Bénédicte

Hi,
 I have read this page: http://wiki.gephi.org/index.php/Troubleshooting

So as explained, I have deleted the directory: /Users/username/Library/Application/Support/gephidesktop

Then I have installed again Gephi and It's OK.

I thing the reason could be an older installation of Gegphi when my computer was in Java 5.0

Thanks
Bénédicte

Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers