dynamic graph unrecognized if everlasting nodes

Bug #555637 reported by paul on 2010-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Unassigned
0.7
Fix Released
Low
Unassigned

Bug Description

A graph whose mode is set to dynamic but which doesn't have any node with a start or end attribute will bot be recognized by gephy as dynamic.

To reproduce it :
- Take the file dynamics.gexf from gexf.net
    $wget http://gexf.net/data/dynamics.gexf

- open it with gephi and check it is well recognized as dynamic

- then edit it and remove only the start="2009-03-01" from node id=0
    <nodes>
          <node id="0" label="Gephi" start="2009-03-01">
becomes
    <nodes>
          <node id="0" label="Gephi" >

- open it again with gephi and see that it is recognized as static

(see http://forum.gephi.org/viewtopic.php?f=4&t=111)

The problem is different: as dynamic attributes are not implemented yet, if nor node nor edge is dynamic, the graph is interpreted as static.

Changed in gephi:
status: New → Won't Fix
importance: Undecided → Low
milestone: none → 0.7alpha3
status: Won't Fix → New

Is fixed with the new GEXF parser

Changed in gephi:
status: New → Fix Committed
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers