Import throws Exception when file is invalid instead of Warning user

Bug #530970 reported by Mathieu Bastian on 2010-03-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Mathieu Bastian
0.7
Fix Released
Low
Unassigned

Bug Description

When Import fails because the imput file cannot be read or parsed, an Exception is thrown, for instance

RuntimeException: Impossible to parse the given XML file

The fact files cannot be read is normal and shouldn't display an exception but a warning dialog.

Changed in gephi:
milestone: 0.7alpha2 → 0.7alpha3
status: Confirmed → Fix Committed
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers