Colors not imported in Pajek Net format

Bug #530028 reported by Mathieu Bastian on 2010-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Wishlist
teto
0.7
Fix Released
Wishlist
teto

Bug Description

Colors are not imported in Pajek files. See Pajek specification.

Changed in gephi:
milestone: none → 0.7alpha3
importance: Low → Wishlist
Changed in gephi:
assignee: Mathieu Bastian (mathieu.bastian) → nobody
teto (elteto1) wrote :

Pajek supports three different colors for a vertex: internal color, border color and label color. I have added support for the internal color in the patch. I tried adding support for label color, but it doesn't to have any effect, also I can't find a way to set the border color directly from the NodeDraft class.

Pajek uses Crayola colors (?!?!?!?!) instead of RGB triplets. Only problem is that they are not standard and they change/are deleted/new ones are added from time to time. I used the following PDF http://vlado.fmf.uni-lj.si/pub/networks/pajek/doc/crayola.pdf from Pajek's website to get a list of the colors they use, but some of them are not even part of Crayola's color list anymore, so I used a combination of Wikipedia and other websites to find matching colors.

Very good, I wonder if the Bundle.properties file is the best place for the color codes. We have a system that reads these files and create localization templates for Launchpad. That may cause some troubles. I think a simple HashMap would be better :-)

Gephi doens't support color borders. Label color is supported but not at the import phase. I guess it could be added to the NodeDraft and EdgeDraft.

teto (elteto1) wrote :

Ok, I moved the colors to a static HashMap and left untouched the .properties file. If Bundle.properties is holding localization stuff I don't think is the right place to hold the values either. I also removed the code for setting label colors since Gephi doesn't support it right now, but it is trivial to add it if in the future. w

Thank you very much Ernesto, it has been applied in rev 2187

Changed in gephi:
assignee: nobody → Ernesto Aneiros (eaneiros)
status: Confirmed → Fix Committed
milestone: 0.7alpha3 → 0.7beta
Changed in gephi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers