[karmic] alltray hides applications from gnome-panel desktop switcher

Bug #118484 reported by Caspar Clemens Mierau on 2007-06-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AllTray
Wishlist
Unassigned
alltray (Gentoo Linux)
New
Undecided
Unassigned
alltray (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alltray

Alltay (at least in Feisty and Edgy) hides applications from the gnome-panel desktop switcher though they are maximized or part of the screen. I guess that this is an upstream problem but it breaks in a way the seamingless usabilty of alltray.

Reproduction:
1. Have Gnome running with desktop/workplace switcher in gnome-panel.
2. Start an application like Evolution, Thunderbird with alltray (e.g. "alltray evolution &" from console).
3. Maximize/Minimize/Hide the Application and check if you can see a "previe" in the desktop/workplace switcher.

Michael B. Trausch (mtrausch) wrote :

Thank you for reporting this bug. Are you still experiencing this issue in the latest stable release of the Ubuntu operating system? Also, could you please describe in more detail what the problem is, if it is still happening?

Changed in alltray:
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in alltray:
status: Incomplete → Invalid
Bruce van der Kooij (brucevdk) wrote :

I can reproduce this bug though I too had some trouble at first understanding what this is about. This is using Metacity.

* Add the workspace switcher to your GNOME panel.
* Start gedit and bring it to the front, you'll notice the gedit icon is being shown in the workplace switcher
* Start alltray and dock gedit
* Show gedit using alltray and make sure it's on top
* The gedit icon will shortly appear in the workplace switcher, but then disappear

Same for the workspace switcher that is brought up using CTRL + ALT + Left arrow / Right Arrow, it shows the icon from the program below the one that is docked (but shown).

Changed in alltray:
status: Invalid → New
midnightflash (midnightflash) wrote :

And the same is to be noticed with Compiz too. (Under Gnome)
(Ubuntu 8.04 [0.69-1ubuntu1], Ubuntu 8.10 [0.69-1ubuntu2] and Gentoo ~386 [x11-misc/alltray-0.69-r1])
Indeed I know this bug ever-since I know alltray.

Changed in alltray:
importance: Undecided → Wishlist
status: New → Confirmed
Michael B. Trausch (mtrausch) wrote :

This bug is fixed in r26 of the old-maintenance branch of AllTray here on Launchpad. Please see the branch that is now associated with this bug.

Changed in alltray:
status: Confirmed → Fix Committed
Michael B. Trausch (mtrausch) wrote :

A debdiff, provided by Kyran Lange, which fixes this bug is available attached to bug 355077 (which also fixes that bug). If someone wants to take a look at it and get these two bugs closed for Jaunty...

Kyran Lange (kyranl) wrote :

The patch for this bug was rejected from bug 355077. Here is a debdiff to fix this bug. It works for me but could some others please test it.
This debdiff is against alltray_0.69-1ubuntu3, which was only recently uploaded so may not have hit your mirror yet.

Changed in alltray (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2009-04-19
summary: - alltray hides applications from gnome-panel desktop switcher
+ [karmic] alltray hides applications from gnome-panel desktop switcher
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alltray - 0.69-1ubuntu4

---------------
alltray (0.69-1ubuntu4) karmic; urgency=low

  * Fix "alltray hides applications from gnome-panel desktop switcher"
    (LP: #118484) by adding 15-dont-remove-from-pager.dpatch

 -- Kyran Lange <email address hidden> Sun, 19 Apr 2009 13:49:12 +0930

Changed in alltray (Ubuntu):
status: Confirmed → Fix Released
Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers