[855gm] 2.6.35-14: Invisible Cursor

Reported by Stenten on 2010-08-06
220
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Gentoo Linux
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

=== Problem ===
A bad commit was introduced between the 2.6.35-rc6 and 2.6.35 kernels which causes the cursor to be invisible on i855 machines. Apart from being invisible, the cursor functions normally. This bug affects the Maverick 2.6.35-14 kernel and onward.

=== Debugging ===
Tested with the mainline kernels:
2.6.35 failed
2.6.35-rc6 passed

Bad commit:
commit b690e96cf9e6a6cde6f0393de47bdd6317ddb5de
Author: Jesse Barnes <email address hidden>
Date: Mon Jul 19 13:53:12 2010 -0700

    drm/i915: add pipe A force quirks to i915 driver

    Ported over from the old UMS list. Unfortunately they're still
    necessary especially on older laptop platforms.

    Fixes https://bugs.freedesktop.org/show_bug.cgi?id=22126.

=== Patch ===
Upstream has produced a patch for this bug. It is available at:
http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git;a=commit;h=532db7fe1fd75f20f3abf959419d160fb7850aff

=== Workarounds ===
Suspend/Resume
VGA output
Check "Show position of pointer when the Control Key is pressed" in System->Preferences->Mouse

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-14-generic 2.6.35-14.19
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: steven 1402 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with STAC9750,51 at irq 5'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 36
   Simple ctrls : 23
Date: Thu Aug 5 21:03:12 2010
HibernationDevice: RESUME=UUID=201bb5f2-1371-4eea-88bd-6204b063567d
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 045e:0750 Microsoft Corp.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude D505
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=49b7ead8-8de5-4040-9bcc-da4f9b1b8f71 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.37
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 11/03/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0H2049
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd11/03/2006:svnDellInc.:pnLatitudeD505:pvr:rvnDellInc.:rn0H2049:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D505
dmi.sys.vendor: Dell Inc.

Stenten (stenten) wrote :
Stenten (stenten) on 2010-08-06
tags: added: kernel-graphics
Stenten (stenten) wrote :

In a strange turn of events, I've discovered I can get the cursor back by suspending/resuming. However, I can't get it back by locking the screen or switching VTs, so it's definitely the actual suspend/resume cycle.

Stenten (stenten) wrote :

dmesg after suspend/resume.

Stenten (stenten) wrote :

Xorg.0.log after suspend/resume.

description: updated
Stenten (stenten) on 2010-08-07
summary: - 2.6.35-14: Invisible Cursor
+ [855gm] 2.6.35-14: Invisible Cursor
tags: added: 855gm pointer
Stenten (stenten) on 2010-08-07
affects: linux (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Stenten (stenten) wrote :

From the upstream report, the bad kernel commit is:

commit b690e96cf9e6a6cde6f0393de47bdd6317ddb5de
Author: Jesse Barnes <email address hidden>
Date: Mon Jul 19 13:53:12 2010 -0700

    drm/i915: add pipe A force quirks to i915 driver

    Ported over from the old UMS list. Unfortunately they're still
    necessary especially on older laptop platforms.

    Fixes https://bugs.freedesktop.org/show_bug.cgi?id=22126.

Ron F. (ronfischler) wrote :

I have a similar problem running Ubuntu Meerkat on an old Dell Latitude D500 that uses Intel GMA 855 graphics hardware. This problem began for me after doing an update a few days ago, and persists after this morning's kernel update. Everything works normally as before, except that I cannot draw a mouse cursor to save my life if the system boots normally. I tried playing with xorg.conf, using vesa driver instead of the default, explicitly turning on the SWCursor, etc. The only thing I found that restores the cursor is choosing Recovery in the Grub menu and then coming up using failsafeX. However, if I copy xorg.conf.failsafe over to xorg.conf and then come up normally - that still does not work.

Strangely when booting normally, even splash works! Just ... no cursor.

I also tried the "sudo lshw -c display" trick suggested in bug #601172, but that hung my system like a horse.

Bryce Harrington (bryce) on 2010-08-08
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Stenten (stenten) on 2010-08-09
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
description: updated
Steve Conklin (sconklin) on 2010-08-09
tags: added: kernel-candidate kernel-reviewed
removed: kernel-needs-review
Stenten (stenten) on 2010-08-11
description: updated
tkbuntu (kingaw1) wrote :

I have the 'invisible cursor' issue also on an IBM Thinkpad R51 MM install which has been updated/upgraded almost daily
uname -r = 2.6.35-14-generic
lspci = VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

I do not have this issue on another MM install, which has not been updated since early August (last update/upgrade just before A3, uname = 2.6.35-7-generic)

Ron F. (ronfischler) wrote :

I noticed this problem after I updated from 2.6.35-13-generic to 2.6.35-14-generic. Now running 2.6.35-15-generic and the problem persists. I continue to make use of the my machine (Dell Latitude D500 with GMA 855) by booting into failsafeX.

sTiLL (stillka) wrote :

same problem on Thinkpad X40 last good kernel was 2.6.35-13-generic.

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Steve W (steve-w) wrote :

same problem on a Sony Vaio x505 (2004 vintage)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Original bug submitter's discovery on how to get the cursor back via a suspend/resume cycle works perfectly.

As annoying as this defect is, 10.10 alpha 3 is miles more usable than 10.04 LTS where the X server would randomly reboot itself, independent of whether KMS was on or off.

wylow (wylow) wrote :

Kernel 2.6.35-17-generic , same problem.

I can confirm that this is most likely a bug in the kernel itself, as I have exact same problem after upgrading to 2.6.35 on Gentoo. Also, suspend/resume brings the cursor back.

Jarkko Lietolahti (jarkko-jab) wrote :

@ranch:~$ uname -a
Linux ranch 2.6.35-19-generic #25-Ubuntu SMP Tue Aug 24 23:09:22 UTC 2010 i686 GNU/Linux
is also affected. Suspend / resume brings the cursor back.

Johannes Dahl (surreal) wrote :

I'm also affected by this bug when running Lucid Lynx with kernel 2.6.35-v9patch1.1 from Brian Roger's PPA for i845 and i855 freezing fixes.

lspci -nn |grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

DrPaulaner (dr-paulaner) wrote :

same in here with a notebook working on an intel Grafikcard

MarcH (marc-herbert-gmail) wrote :

Confirmed kernel 2.6.35-20-generic #29 still buggy on 82852/855GM.
See also https://bugs.archlinux.org/task/20373

Glen Mehn (gmehn) wrote :

Confirmed kernel 2.6.35-20-generic on 686 with an IBM X40 (Intel 855GM): Invisible mouse pointer which comes back after suspend/resume.

Peter Klotz (peter-klotz) wrote :

Also here on an Acer TravelMate 662 (Intel 855GM).

It would be great to have this bug fixed in Maverick. The Suspend/Resume workaround is not really an option for desktop usage with daily reboots.

I also have the invisible cursor problem, but a recent PPA kernel by Brian Rogers includes a fix. For those having an invisible cursor at boot, you may wish to briefly test that kernel to see if it fixes the problem for you. Please be aware that the kernel is primarily intended to fix Bug 541511, so if you're not suffering other i855 problems then you will probably want to avoid the test kernel.

The PPA is located here:
https://launchpad.net/~brian-rogers/+archive/graphics-fixes

You should also read through the i855 master bug (above) because it details other fixes that are/are not working for people with a wide variety of i855 machines.

priyank566 (priyank-patel566) wrote :

I am using HP pavillion dv1000 series which is about 4-5 years old and have i855 GM/GME graphics card.
 I found that the kernel version which comes with the installation of Maverik meeerkat beta release or any daily version nowadays makes the mouse pointer invisible or you can say suspend/resume pointer sickness
Also I tested this beta release and daily build releases with kernel "2.6.35-rc6-maverick" worked fully functional
so untill this problem is solved with new developing kernel I recommend using above mentioned kernel.
Plz mail me on any problem and if this solved your problem.
link for the kernel is "http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc6-maverick/" without quotes.

Stenten (stenten) wrote :

To those who are commenting, PLEASE read the description before commenting. This bug is already confirmed, so any further confirmation posts are superfluous and only congest the bug report, making it harder to find useful posts which contain new information. It is also already known that the last working kernel is the rc6 kernel, and that suspend/resume fixes the problem.

If you have additional information to provide that is not in the description, please post it. But if not, please click "This bug affects me too" at the top, follow this report and the upstream report, and patiently wait for a fix or something to test. Thank you.

Stenten (stenten) wrote :

Upstream has produced a patch which appears to fix this bug. It is located at:

http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git;a=commit;h=532db7fe1fd75f20f3abf959419d160fb7850aff

tags: added: patch
Stenten (stenten) on 2010-09-12
description: updated
Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released

Hi Stenten,

I've built a test kernel with the patch applied from comment #22. Care to give it a try and let me know if this fixes up the issue you reported here? Thanks.

http://people.canonical.com/~ogasawara/lp614176/i386/

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: Confirmed → In Progress
Peter Klotz (peter-klotz) wrote :

Hello Leann

In my case (Acer TravelMate 662, i855GM) your test kernel fixes the issue. The mouse cursor is back!

Thanks a lot to all people who have contributed to the fix.

Stenten (stenten) wrote :

Hi Leann,

After upgrading my system, I've discovered that the cursor is back. I'm pretty sure it's the fbdev driver that restored the cursor, because the xorg-server containing that switch was one of the updates, and now my -20 kernel has a working cursor (it didn't before the upgrades).

If it's any consolation, I tested the patched -22 kernel and it didn't regress anything compared to the default -22 kernel.

Peter Klotz (peter-klotz) wrote :

@Stenten

I made a similar observation. My machine runs Lucid and mainline 2.6.35.4 never showed a mouse cursor.

The test kernel made it appear and now even 2.6.35.4 works correctly.

I did however *not* install any updates (xorg,...) that could explain that.

Could this mean that booting the test kernel once fixes the issue permanently? Sounds unlikely.

Stenten (stenten) wrote :

Sorry, I don't think I was very clear. When I said I "upgraded", all I did was "apt-get update && apt-get upgrade" and the cursor is back.

On 09/17/2010 07:23 PM, Stenten wrote:
> Sorry, I don't think I was very clear. When I said I "upgraded", all I
> did was "apt-get update && apt-get upgrade" and the cursor is back.
>

I can confirm this, too. After upgrading the system today, the mouse
pointer is back. No need to install Leann's kernel package.

--
Arne Götje (高盛華) <email address hidden>
PGP/GnuPG key: 1024D/685D1E8C
Fingerprint: 2056 F6B7 DEA8 B478 311F 1C34 6E9F D06E 685D 1E8C
Key available at wwwkeys.pgp.net. Encrypted e-mail preferred.

Hi All,

Thanks for all the testing and feedback. Considering Stenten (the original bug reporter) and others have confirmed that this has been resolved after pulling the latest updates I'll just go ahead and mark this Fix Released. If anyone else is still experiencing issues even after the latest updates, please open a new bug. Thanks!

Changed in linux (Ubuntu):
assignee: Leann Ogasawara (leannogasawara) → nobody
status: In Progress → Fix Released
John Parrish (jp-dcresearch) wrote :

I just downloaded the beta of Ubuntu on 9/24/2010 Late in the evening US Pacific time. This beta release has this "vanished mouse" in the desktop i386 ISO.

lspci -nn |grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

Since this bug was marked fixed nearly a week ago I thought I'd indicate that the ISO being distributed wasn't fixed as it operated in Live CD and in "Installer Mode".

John, thanks for taking the time to report this bug to make Ubuntu better!

Please try updating to the latest versions of all packages in Ubuntu to see if you still experience the invisible cursor problem. To get the cursor back, try putting your machine to sleep using the hardware buttons on your keyboard and then waking the machine up; for many of us this step restores the mouse cursor.

Then login to the desktop and update Ubuntu using the steps here:
https://help.ubuntu.com/10.04/keeping-safe/C/updates.html

Since you will be updating your kernel image, you will need to reboot the system after updating everything. The final release images of Maverick Meerkat will have the fix included. If updating to the latest package versions does not restore your mouse cursor, then please submit another report here.

znejk (hedstrom79) wrote :

Installed Ubuntu 10.10 some days ago (with full updates today) and also having this problem with the invisible cursor. Read somewhere that there is a fix. Is it gonna be in the ubuntu update or are we with old 855gm card gonna have to h4x0r our way to get working compiz and mouse. (The suspend workaround only worked for me once, and the mouse returned. But all the other times I only get black screen :( )

Stenten (stenten) wrote :

znejk,

Please read Comment #29, specifically the part that says "If anyone else is still experiencing issues even after the latest updates, please open a new bug. Thanks!"

(You can file a bug against the kernel by typing "ubuntu-bug linux" into a terminal.)

Otto Kekäläinen (otto) wrote :

Could this be a duplicate of bug #492782 ?
Is the patch related just to Intel drivers or could it be made to fix similar issues on Nvidia and ATI cards also?

Stenten (stenten) wrote :

Otto Kekäläinen,

No, Bug 492782 is different for many reasons, including 1) the symptoms are different, 2) the hardware is different, 3) this bug is in the drm/i915 KMS driver, not the nouveau or radeon drivers, and 4) the timeline doesn't match with the introduction of this bug.

Bug still present in latest kernel 2.6.35-22.34, after installing Leann Ogasawara older kernel cursor is visible again.

Stenten (stenten) wrote :

Vladimir Psenicka,

Please see Comment #29. The correct way to file a new bug against the kernel is to run "ubuntu-bug linux" in a terminal.

Hi there...

Video Specs: i855g

I am using ubuntu 10.10 as well, but i am using the fixed driver from stefan...
got no cursor issues... using DRI 3D accelerator i get Full HD video playback
and EXCELLENT frame rates for streaming videos in Firefox, i do not use
Totem but VLC for video playback... However i can not get Compiz to activate
desktop effects... let me know if you have heard of a fix, i did a lot of googling
with no potential solutions. Thinking of downgrading to 10.04 just for desktop
effects seems stupid to me as i am aware that X is sometimes crashing with
that LTS release...

Any input would be appreciated...

t3xtm0d3 h4x0r.

Changed in linux:
importance: Medium → Unknown
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.