Grail backend does not populate device X and Y axis attributes

Bug #987539 reported by Chase Douglas
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Geis
Medium
Unassigned
utouch-geis (Ubuntu)
Medium
Stephen M. Webb
Precise
Medium
Unassigned

Bug Description

The GEIS_DEVICE_ATTRIBUTE_{MIN,MAX,RES}_{X,Y} attributes are not defined.

Related branches

Changed in utouch-geis (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Stephen M. Webb (bregma)
Changed in utouch-geis:
status: Triaged → In Progress
Changed in utouch-geis (Ubuntu Precise):
status: Triaged → In Progress
Changed in utouch-geis (Ubuntu):
status: Triaged → In Progress
Stephen M. Webb (bregma)
Changed in utouch-geis:
assignee: nobody → Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu Precise):
assignee: nobody → Stephen M. Webb (bregma)
Stephen M. Webb (bregma)
Changed in utouch-geis:
status: In Progress → Fix Committed
Revision history for this message
Stephen M. Webb (bregma) wrote :

Debdiff to most recent utouch-geis package in Ubuntu 12.04

Revision history for this message
Stephen M. Webb (bregma) wrote :

Build log

Revision history for this message
Stephen M. Webb (bregma) wrote :
Changed in utouch-geis (Ubuntu Precise):
status: In Progress → New
Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu Precise):
assignee: Stephen M. Webb (bregma) → nobody
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Chase, or anyone else affected,

Accepted utouch-geis into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in utouch-geis (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Chase Douglas (chasedouglas) wrote :

I have verified that the device X and Y axis values are provided in libutouch-geis1_2.2.9-0ubuntu3 in precise-proposed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package utouch-geis - 2.2.9-0ubuntu3

---------------
utouch-geis (2.2.9-0ubuntu3) precise-proposed; urgency=low

  [ Chase Douglas ]
  * fixed calculation of touch deltas (lp: #985916)
  * calculated pinch radius delta as ratio (lp: #986215)
  * fixed a C++ compile fail due to enum types (lp: #813819)

  [ Stephen M. Webb ]
  * added device axis attributes (regression) (lp: #987539)
 -- <email address hidden> (Stephen M. Webb) Fri, 27 Apr 2012 13:10:00 -0400

Changed in utouch-geis (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in utouch-geis:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in utouch-geis (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma)
Changed in utouch-geis:
status: Fix Committed → Fix Released
assignee: Stephen M. Webb (bregma) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers