Position deltas are incorrect when synchronous events are not enabled

Bug #985916 reported by Chase Douglas
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Geis
Medium
Chase Douglas
utouch-geis (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

The default is that multiple synchronous events, sequential events with the same timestamp, are not sent. The fix for bug 967267 caused the delta values in the next non-synchronous events to be incorrect. Instead of reporting the full delta between the each non-synchronous event, the deltas reported are between the last event from grail and the current event.

This causes Unity window dragging to be slower than it should be because the position deltas are less than they should be.

Related branches

Changed in utouch-geis (Ubuntu):
importance: Undecided → Medium
Changed in utouch-geis:
status: In Progress → Fix Committed
Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu):
status: New → In Progress
Changed in utouch-geis (Ubuntu Precise):
status: New → In Progress
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Chase, or anyone else affected,

Accepted utouch-geis into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in utouch-geis (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Chase Douglas (chasedouglas) wrote :

I have verified that the position deltas are appropriate now for all events. This is best tested by checking whether windows move with the touches when performing a three-touch drag in Unity. Everything works properly now, confirming this bug has been fixed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package utouch-geis - 2.2.9-0ubuntu3

---------------
utouch-geis (2.2.9-0ubuntu3) precise-proposed; urgency=low

  [ Chase Douglas ]
  * fixed calculation of touch deltas (lp: #985916)
  * calculated pinch radius delta as ratio (lp: #986215)
  * fixed a C++ compile fail due to enum types (lp: #813819)

  [ Stephen M. Webb ]
  * added device axis attributes (regression) (lp: #987539)
 -- <email address hidden> (Stephen M. Webb) Fri, 27 Apr 2012 13:10:00 -0400

Changed in utouch-geis (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in utouch-geis (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma)
Changed in utouch-geis:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers