plugin Activation failed after package installation

Bug #1046288 reported by Alexis Clairet
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gedit Project Manager
Undecided
Unassigned

Bug Description

I tried to install project-manager (from apt) and a message tells me that "when installing manually i need to copy gschemes" (similar bug listed)
I installed classbrowser3g and from now i can use project manager. There might be missing files in the project-manager package ?

Revision history for this message
B. Clausius (barcc) wrote :

The message "GSettings schema for the Projects Plugin is not installed. ..." shows up when the plugin is installed while gedit is running. A restart of gedit should resolve the issue.

Can you confirm that gedit was running while you installed the plugin?
In this case I would just improve the message to be more precise.

B. Clausius (barcc)
Changed in gedit-projects:
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for Gedit Project Manager because there has been no activity for 60 days.]

Changed in gedit-projects:
status: Incomplete → Expired
Revision history for this message
Dang (dangus) wrote :

I ran gedit on MacOSx 10.6.8 and got similar error. There is no /usr/share/glib-2.0/schemas/ so I created it manually when setup the plugin and did:
        sudo cp *.gschema.xml /usr/share/glib-2.0/schemas/
        sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

From console, the command "gsettings list-schemas" returns just "org.gnome.gedit.plugins.projects"

I tried to look into the config.py code and added a dialog to show schemas list before if self.settings_schema not in schemas:

It shows up below list without org.gnome.gedit.plugins.projects. But I don't know how to fix. That's weird because the command
"gsettings list-schemas" just returns "org.gnome.gedit.plugins.projects" while the python code returns a long list.

org.gnome.gedit.plugins.time, org.gnome.gedit.plugins.externaltools, org.gnome.gedit.preferences.print, org.gnome.gedit.preferences, ca.desrt.dconf-editor.Settings, org.gnome.desktop.default-applications, org.gnome.gedit.plugins, org.gnome.desktop.default-applications.office.calendar, org.gnome.desktop.media-handling, org.gnome.system.proxy.http, org.gnome.gedit.plugins.filebrowser, org.gnome.desktop.default-applications.terminal, org.gnome.system.proxy.socks, org.gnome.desktop.default-applications.office, org.gnome.desktop.a11y.magnifier, org.gnome.gedit.preferences.editor, org.gnome.system.locale, org.gnome.gedit.plugins.filebrowser.nautilus, org.gnome.desktop.screensaver, org.gnome.desktop.a11y.keyboard, org.gnome.system.proxy, org.gnome.gedit.state.history-entry, org.gnome.system.proxy.https, org.gnome.desktop.a11y.applications, org.gnome.gedit.plugins.checkupdate, org.gnome.gedit.plugins.drawspaces, org.gnome.gedit, org.gnome.desktop.default-applications.office.tasks, org.gnome.desktop.sound, org.gnome.desktop.session, org.gnome.desktop.thumbnail-cache, org.gnome.desktop.background, org.gnome.gedit.preferences.encodings, org.gnome.desktop.thumbnailers, org.gnome.system.proxy.ftp, org.gnome.gedit.plugins.pythonconsole, org.gnome.desktop.a11y.mouse, org.gnome.gedit.state.window, org.gnome.gedit.preferences.ui, org.gnome.gedit.state.file-filter, org.gnome.desktop.lockdown, org.gnome.desktop.interface, org.gnome.gedit.state

Revision history for this message
B. Clausius (barcc) wrote :

Could you please open a new bug report since your problem is unrelated to this bug report. This bug is about automatic installation using a package manager on (probably) Ubuntu and your problem is about manual installation on MacOS. Please add there the output of "echo $XDG_DATA_DIRS"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers