GPL Electronic Design Automation tools

program to diff schematics

Reported by ahvezda on 2006-03-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gEDA
Medium
Unassigned

Bug Description

It would be most cool if you could load 2 schematics,
display one in color #1, the other in color #2, and
make an XOR of the two blink. I'd think it wouldn't be
too hard, but it might be a nice way to visually see a
diff between schematics.

Of course, fully dealing with changed invisible
attributes, renumbered designs, etc might be more of a
challenge, but the XOR could be useful.

Originally suggested by Dan McMahill
Tue, 30 Nov 2004 18:14:10

Alan Somers (asomers) wrote :

Here's a patch. I hope you won't mind that it's 7 years late :)

The technique is based on this article: http://www.evilmadscientist.com/article.php/visdiff . It integrates with mercurial, git, and subversion. And it doesn't show unprintable features like invisible attributes; you'll still have to use the standard text diff to see those.

Peter Clifton (pcjc2) wrote :

Alan - that looks _awesome_

I would invite you to make an announcement on the geda-user email list, as I'm sure there will be a lot of people who find this very interesting.

Thank you! Actually, I've already sent an announcement, but it's
waiting for the moderator.

On Sun, Oct 2, 2011 at 5:20 PM, Peter Clifton <email address hidden> wrote:
> Alan - that looks _awesome_
>
> I would invite you to make an announcement on the geda-user email list,
> as I'm sure there will be a lot of people who find this very
> interesting.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/698744
>
> Title:
>  program to diff schematics
>
> Status in GPL Electronic Design Automation tools:
>  New
>
> Bug description:
>  It would be most cool if you could load 2 schematics,
>  display one in color #1, the other in color #2, and
>  make an XOR of the two blink.  I'd think it wouldn't be
>  too hard, but it might be a nice way to visually see a
>  diff between schematics.
>
>  Of course, fully dealing with changed invisible
>  attributes, renumbered designs, etc might be more of a
>  challenge, but the XOR could be useful.
>
>  Originally suggested by Dan McMahill
>  Tue, 30 Nov 2004 18:14:10
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/geda/+bug/698744/+subscriptions
>

Alan Somers (asomers) wrote :

I forgot to include a necessary .scm file in the previous patch. This patch replaces the previous one.

Peter Clifton (pcjc2) wrote :

Ah - the moderated lists are the _old_ gEDA mailing lists. They were shutdown recently, and the official lists moved here:

<email address hidden>

Subscribe at http://www.delorie.com/listserv/

Peter TB Brett (peter-b) wrote :

Hi Alan, this looks great! The only problem is that you don't provide a manpage. Also, you could avoid the need for the separate Scheme script if you used gschem -c "<Scheme code>"

Hopefully we can get this into gEDA soon.

Changed in geda:
importance: Wishlist → Medium
milestone: none → 1.8.0
status: New → Confirmed
Alan Somers (asomers) wrote :

Peter, can you show me an example usage of gschem -c ? Everything I try produces the error

ERROR: Wrong type (expecting string): #f

Peter TB Brett (peter-b) wrote :

gschem -c "(display 'magic) (gschem-exit)"

works for me, with git master. What's your gschem --version?

Alan Somers (asomers) wrote :

I think I must've had a build error. At any rate, it works now with your style of quoting. Here's a new patch.

Peter TB Brett (peter-b) wrote :

I've committed this -- thanks! The robot won't be along to close the bug automatically because I put the wrong bug number in the commit message. :-(

commit 79713159cdb78fc17f48c7cd2ad34c130a33fb96
Author: Alan Somers <email address hidden>
Date: Thu Dec 15 08:33:19 2011 +0000

    schdiff, a graphical diff tool for schematics.

    Closes-bug: lp-1442898

Changed in geda:
milestone: 1.8.0 → 1.7.2
status: Confirmed → Fix Committed
Peter TB Brett (peter-b) on 2012-01-01
Changed in geda:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers