Worker exits due to NPE if function throws an exception without a message

Bug #615700 reported by Eric Lambert on 2010-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gearman Java
Medium
Eric Lambert

Bug Description

If the call() method for a particular Function results in an exception being raised and that if that exception object does not have a message --which is to say that a call to getMessage() on the exception returns null-- then the worker will crash due to an NPE

Related branches

Eric Lambert (elambert) on 2010-08-10
Changed in gearman-java:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Eric Lambert (elambert)
milestone: none → 0.04
Eric Lambert (elambert) on 2010-08-11
Changed in gearman-java:
status: Confirmed → Fix Committed
Eric Lambert (elambert) on 2010-09-10
Changed in gearman-java:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers