Worker should be able to execute GRAB_JOB_UNIQ

Bug #1098816 reported by Eric Lambert on 2013-01-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gearman Java
High
Eric Lambert

Bug Description

Currently the worker can not make GRAB_JOB_UNIQ requests to the server and instead only makes GRAB_JOB request. As such if a job has been assigned a UUID the worker will never receive the UUID as the UUID is not include in the JOB_ASSIGN packet that results from GRAB_JOB requests.

see https://answers.launchpad.net/gearman-java/+question/218865 for further details

Eric Lambert (elambert) on 2013-01-12
Changed in gearman-java:
status: New → In Progress
Eric Lambert (elambert) wrote :

Hi Khai:

I've pushed a fix for this. The behavior of the worker can be toggled with the setJobUniqueIdRequired() method. When set to true, the worker will perform GRAB_JOB_UNIQ requests against the server (which instructs the server to include the unique value, as set by the client, in the job assignment). Functions can access this value with getUniqueId().

Please let me if this solves your problem.

Eric

Changed in gearman-java:
status: In Progress → Fix Committed
Khai Do (zaro0508) wrote :

I have confirmed that this bug is fixed. Solved my problem and is working great, Thanks!

Hi Eric, Thanks for fixing, works great. Could you please deploy to the
hosted repository so my build can pick up the latest? it's
http://dev.nightlabs.org/maven-repository/repo/ right?

Thanks.
-Khai

On Sun, Feb 24, 2013 at 4:06 PM, Eric Lambert <email address hidden>wrote:

> Hi Khai:
>
> I've pushed a fix for this. The behavior of the worker can be toggled
> with the setJobUniqueIdRequired() method. When set to true, the worker
> will perform GRAB_JOB_UNIQ requests against the server (which instructs
> the server to include the unique value, as set by the client, in the job
> assignment). Functions can access this value with getUniqueId().
>
> Please let me if this solves your problem.
>
> Eric
>
>
> ** Changed in: gearman-java
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1098816
>
> Title:
> Worker should be able to execute GRAB_JOB_UNIQ
>
> Status in Gearman Java:
> Fix Committed
>
> Bug description:
> Currently the worker can not make GRAB_JOB_UNIQ requests to the server
> and instead only makes GRAB_JOB request. As such if a job has been
> assigned a UUID the worker will never receive the UUID as the UUID is
> not include in the JOB_ASSIGN packet that results from GRAB_JOB
> requests.
>
> see https://answers.launchpad.net/gearman-java/+question/218865 for
> further details
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gearman-java/+bug/1098816/+subscriptions
>

Eric Lambert (elambert) wrote :

Sure, I'll try and take care of that tonight

On Feb 25, 2013, at 5:34 PM, Khai Do <email address hidden> wrote:

> Hi Eric, Thanks for fixing, works great. Could you please deploy to the
> hosted repository so my build can pick up the latest? it's
> http://dev.nightlabs.org/maven-repository/repo/ right?
>
> Thanks.
> -Khai
>
>
> On Sun, Feb 24, 2013 at 4:06 PM, Eric Lambert <email address hidden>wrote:
>
>> Hi Khai:
>>
>> I've pushed a fix for this. The behavior of the worker can be toggled
>> with the setJobUniqueIdRequired() method. When set to true, the worker
>> will perform GRAB_JOB_UNIQ requests against the server (which instructs
>> the server to include the unique value, as set by the client, in the job
>> assignment). Functions can access this value with getUniqueId().
>>
>> Please let me if this solves your problem.
>>
>> Eric
>>
>>
>> ** Changed in: gearman-java
>> Status: In Progress => Fix Committed
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1098816
>>
>> Title:
>> Worker should be able to execute GRAB_JOB_UNIQ
>>
>> Status in Gearman Java:
>> Fix Committed
>>
>> Bug description:
>> Currently the worker can not make GRAB_JOB_UNIQ requests to the server
>> and instead only makes GRAB_JOB request. As such if a job has been
>> assigned a UUID the worker will never receive the UUID as the UUID is
>> not include in the JOB_ASSIGN packet that results from GRAB_JOB
>> requests.
>>
>> see https://answers.launchpad.net/gearman-java/+question/218865 for
>> further details
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/gearman-java/+bug/1098816/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1098816
>
> Title:
> Worker should be able to execute GRAB_JOB_UNIQ
>
> Status in Gearman Java:
> Fix Committed
>
> Bug description:
> Currently the worker can not make GRAB_JOB_UNIQ requests to the server
> and instead only makes GRAB_JOB request. As such if a job has been
> assigned a UUID the worker will never receive the UUID as the UUID is
> not include in the JOB_ASSIGN packet that results from GRAB_JOB
> requests.
>
> see https://answers.launchpad.net/gearman-java/+question/218865 for
> further details
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gearman-java/+bug/1098816/+subscriptions

Hi Khai:

The snap-shot has been deployed to the sonatype repo ( http://oss.sonatype.org/content/repositories/snapshots/org/gearman/gearman-java/0.6-SNAPSHOT )

Eric

On Feb 25, 2013, at 5:34 PM, Khai Do wrote:

> Hi Eric, Thanks for fixing, works great. Could you please deploy to the
> hosted repository so my build can pick up the latest? it's
> http://dev.nightlabs.org/maven-repository/repo/ right?
>
> Thanks.
> -Khai
>
>
> On Sun, Feb 24, 2013 at 4:06 PM, Eric Lambert <email address hidden>wrote:
>
>> Hi Khai:
>>
>> I've pushed a fix for this. The behavior of the worker can be toggled
>> with the setJobUniqueIdRequired() method. When set to true, the worker
>> will perform GRAB_JOB_UNIQ requests against the server (which instructs
>> the server to include the unique value, as set by the client, in the job
>> assignment). Functions can access this value with getUniqueId().
>>
>> Please let me if this solves your problem.
>>
>> Eric
>>
>>
>> ** Changed in: gearman-java
>> Status: In Progress => Fix Committed
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1098816
>>
>> Title:
>> Worker should be able to execute GRAB_JOB_UNIQ
>>
>> Status in Gearman Java:
>> Fix Committed
>>
>> Bug description:
>> Currently the worker can not make GRAB_JOB_UNIQ requests to the server
>> and instead only makes GRAB_JOB request. As such if a job has been
>> assigned a UUID the worker will never receive the UUID as the UUID is
>> not include in the JOB_ASSIGN packet that results from GRAB_JOB
>> requests.
>>
>> see https://answers.launchpad.net/gearman-java/+question/218865 for
>> further details
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/gearman-java/+bug/1098816/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1098816
>
> Title:
> Worker should be able to execute GRAB_JOB_UNIQ
>
> Status in Gearman Java:
> Fix Committed
>
> Bug description:
> Currently the worker can not make GRAB_JOB_UNIQ requests to the server
> and instead only makes GRAB_JOB request. As such if a job has been
> assigned a UUID the worker will never receive the UUID as the UUID is
> not include in the JOB_ASSIGN packet that results from GRAB_JOB
> requests.
>
> see https://answers.launchpad.net/gearman-java/+question/218865 for
> further details
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gearman-java/+bug/1098816/+subscriptions

Eric Lambert (elambert) on 2013-04-03
Changed in gearman-java:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions