gdm

cursor should not show during xsplash startup

Bug #432179 reported by Rick Spencer on 2009-09-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
Low
Cody Russell
gdm
New
Low
David Barth
xsplash
Low
Cody Russell
xsplash (Ubuntu)
Low
Cody Russell

Bug Description

Binary package hint: xsplash

Currently uses see the ubuntu mouse cursor spinning while xsplash is running. This is not useful and doesn't look good. It should show for GDM and the desktop, but not while xsplash is running.

ProblemType: Bug
Architecture: i386
Date: Thu Sep 17 16:22:55 2009
DistroRelease: Ubuntu 9.10
Package: xsplash 0.8.1-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SourcePackage: xsplash
Uname: Linux 2.6.31-10-generic i686

Related branches

Changed in xsplash (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Cody Russell (bratsche)
milestone: none → ubuntu-9.10-beta
importance: Medium → Low
Changed in xsplash:
importance: Undecided → Low
assignee: nobody → Cody Russell (bratsche)
milestone: none → ubuntu-9.10-beta-freeze

Perhaps this is really in GDM?

Changed in xsplash:
assignee: Cody Russell (bratsche) → David Barth (dbarth)
tags: added: ubuntu-boot
Changed in xsplash (Ubuntu):
assignee: Cody Russell (bratsche) → David Barth (dbarth)
affects: xsplash → gdm
Changed in gdm:
milestone: ubuntu-9.10-beta-freeze → none
Changed in xsplash:
importance: Undecided → Low
assignee: nobody → David Barth (dbarth)
milestone: none → ubuntu-9.10-beta-freeze
Changed in xsplash (Ubuntu):
status: New → Invalid
David Barth (dbarth) wrote :

Here is a patch that removes busy cursor in most cases. I've kept it for xdmcp to still give some feedback in this case. Otherwise for local displays gdm should now not let the cursor "blink" anymore.

David Barth (dbarth) wrote :

I've tested the patch both with the greeter and in the autologin case. No side effects identified on my (slow) netbook.

Changed in gdm:
status: New → Fix Committed
Ken VanDine (ken-vandine) wrote :

Packaging for gdm pushed to lp:~ubuntu-desktop/gdm/ubuntu

Sebastien Bacher (seb128) wrote :

the change seems rather a workaround no? why should gdm show no busy cursor? what if people don't use xsplash?

Sebastien Bacher (seb128) wrote :

I've undone the change in bzr for now since it seems not correct and rather a workaround, could you at least explain what the change is supposed to do exactly, why can't xsplash be changed rather and what happens to users not have xsplash installed? the change should also be taken upstream if it makes sense in all cases

Changed in gdm:
status: Fix Committed → New

I suggest that we punt this bug to Lucid. It seems that there may be issues to discuss regarding how to fix it. There are too many Critical and High bugs in the Karmic ATM to warrant effort on priority = Low.

Changed in xsplash:
milestone: ubuntu-9.10-beta-freeze → none
Changed in xsplash (Ubuntu):
milestone: ubuntu-9.10-beta → none
David Barth (dbarth) on 2009-10-02
Changed in xsplash:
milestone: none → ubuntu-9.10
status: New → Triaged
Changed in ayatana-ubuntu:
assignee: nobody → David Barth (dbarth)
importance: Undecided → Low
milestone: none → ubuntu-9.10
status: New → Triaged
HBLaw (huangbolaw) wrote :

It's like you see a delicious dish of food with a dead fly on the CENTER of it. A lot of work can be done on other bugs, but all those work will not have any positive effect if people feel bad. :-) People will not know that ubuntu team has fixed so many bugs that prevented so many problems (say those crashes happen to 1% of people) but everyone will notice (sort of) the ugliness by placing a cursor in the middle of the screen breaking all the supposed aesthetic value xsplash is to give.

Best Regards
Bo

Cody Russell (bratsche) wrote :

Maybe some people in certain parts of the world like flies as a source of protein?

HBLaw (huangbolaw) wrote :

:-0 That explains.

If a cursor in absolutely needed, can anyone makes it transparent? :-)

Cody Russell (bratsche) wrote :

We already set the cursor to blank. If you start xsplash from a terminal you'll see that the cursor is invisible. I'm not sure why the cursor is visible when you login, but I'm sure it's probably for some really weird crazy reason and that's why this bug is marked as low priority.

Cody Russell (bratsche) wrote :

The branch I attached seems to fix it. This sets a blank cursor on the foreign cow window (which I actually didn't think you could do, but apparently I was wrong).

Changed in xsplash:
assignee: David Barth (dbarth) → Cody Russell (bratsche)
Changed in xsplash (Ubuntu):
assignee: David Barth (dbarth) → Cody Russell (bratsche)
Changed in ayatana-ubuntu:
assignee: David Barth (dbarth) → Cody Russell (bratsche)
Changed in xsplash:
status: Triaged → In Progress
HBLaw (huangbolaw) wrote :

I did not know that the cursor has already been removed (from the code). Do you mean that if everything runs as designed there will not be a cursor? (On my machine it is a round cursor ie. "busy"). I thought this aesthetic issue has been ignored from the posts above.

But if it is just me, how can I identify the problem? Is there any configuration files I can do? Does remove --purge and reinstall resolve the problem?

Best Regards,
Bo

Cody Russell (bratsche) wrote :

In X you can't just turn off the cursor globally, and a lot of people seem to be expecting that to happen. You can only set a cursor bitmap on a specific window. What was happening in xsplash so far is that I set a blank cursor on the xsplash window, and if you ran xsplash from a terminal you would not see the cursor. But when you logged in you would see the cursor when it appeared to be over the xsplash window.

The problem is that we're starting xsplash before compiz starts, and for reasons I'm not going to describe in depth here we also initialize the X compositing overlay window. So right now when you've seen a cursor over the xsplash window, it's actually been because your mouse cursor is on the cow, not on xsplash. You'll still see a brief time where the cursor becomes visible and then invisible again, and that's when compiz starts and takes over the cow. Talking to a compiz developer, I believe there is no solution to that right now.

I propose that we consider this a relatively minor issue, and focus on crashers and other High or Critical priority bugs for the rest of Karmic. We should move this into Lucid though, as solve this as we refine the start up experience in 10.04.

Cody Russell (bratsche) on 2009-10-05
Changed in xsplash:
status: In Progress → Fix Committed
Changed in ayatana-ubuntu:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.8.3-0ubuntu1

---------------
xsplash (0.8.3-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #446658)
    - watch for monitors-changed signal (LP: #413348)
    - set a blank cursor on the cow foreign window (LP: #432179)
    - setgid fixes (LP: #439268)
    - 16bpp depth fixes (LP: #423632)
  * debian/patches/90_correctly-setuid.patch
    - Removed, merged upstream

 -- Ken VanDine <email address hidden> Fri, 09 Oct 2009 08:16:49 +0200

Changed in xsplash (Ubuntu):
status: Invalid → Fix Released
Cody Russell (bratsche) on 2009-10-09
Changed in xsplash:
status: Fix Committed → Fix Released
Changed in ayatana-ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers