right clicking on systray icon can't work after adding an applet

Bug #197991 reported by Xiyue Deng
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gDesklets
Medium
Unassigned

Bug Description

In gdesklets 0.36, right clicking on systray icon will get no responding after adding an applet. Doesn't happen in <= 0.35.4 .

Revision history for this message
MarioGonzalez (gonzalemario) wrote :

Try this:

- remove the applet
- stop daemon
- start daemon
- add the applet

Does the bug show up again? if this so, can you please send us the log file or the backtrace or more information about this?

Changed in gdesklets:
status: New → In Progress
status: In Progress → Incomplete
Revision history for this message
Xiyue Deng (manphiz) wrote :

Yea it showed up again. After looking at the log, it seems it's caused by the following error:

[EXC]TrayIcon instance has no attribute '_TrayIcon__menu'

I've attached the full log below.

My system is Debian sid, updated to latest. Here's the information of gdesklets' dependencies:

ii gdesklets-data 0.35.6-2
ii libatk1.0-0 1.22.0-1
ii libc6 2.7-9
ii libcairo2 1.4.14-1
ii libffi4 4.3.0-1
ii libglib2.0-0 2.16.1-1
ii libgtk2.0-0 2.12.8-1
ii libgtop2-7 2.20.2-1
ii libpango1.0-0 1.20.0-1
ii librsvg2-2 2.22.2-2
ii python 2.4.4-6
ii python-gnome2 2.20.1-2
ii python-gtk2 2.12.1-1
ii python-numeric 24.2-8.2
ii python-pyorbit 2.14.3-2
ii python-support 0.7.6
ii python-xml 0.8.4-10
dxy@debian:~/.gdesklets/lo

Revision history for this message
MarioGonzalez (gonzalemario) wrote :

I have tried 0.36 and 0.36.1beta and I have installed some remote packages. However I cannot confirm this and I think out upstream version is not the problem, perhaps Debian has got a modified version.

How did you install gDesklets on your box?

Revision history for this message
Xiyue Deng (manphiz) wrote :

I'm one of the maintainers of Debian gdesklets package. We packaged the one downloaded from http://www.gdesklets.de/files/gdesklets-0.36.tar.bz2 . According to the log, the missing attribute from TrayIcon looks like a ABI incompatibility in python-gtk2 or python-gnome, or Python itself. Please compare your development environment with the one of mine.

Revision history for this message
MarioGonzalez (gonzalemario) wrote :

Bug #229506 include a related bug which was fixed in 0.3x

Can someone reproduce this bug? In other case we should close it.

Changed in gdesklets:
importance: Undecided → Medium
status: Incomplete → In Progress
Revision history for this message
Xiyue Deng (manphiz) wrote :

在 2008-06-27五的 22:19 +0000,MarioGonzalez写道:
> Bug #229506 include a related bug which was fixed in 0.3x
>
> Can someone reproduce this bug? In other case we should close it.
>

It seems the patch provided in #229506 fixes the problem. Tested at my
place. Feel free to close it if no other reports come up during the
test period.

> ** Changed in: gdesklets
> Importance: Undecided => Medium
> Status: Incomplete => In Progress
>
--
Regards,
Deng Xiyue, a.k.a. manphiz

Revision history for this message
Bjoern Koch (h.humpel) wrote :

> It seems the patch provided in #229506 fixes the problem.
> Feel free to close it if no other reports come up during
> the test period.

OK: no other reports within 10 month -> closing this one

Changed in gdesklets:
status: In Progress → Fix Committed
Bjoern Koch (h.humpel)
Changed in gdesklets:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers