Comment 0 for bug 591470

gdebi crashes when I try to install the package: liferea-data_1.7.4-2~llfsyncfix1+sikon8_all.deb from https://edge.launchpad.net/~sikon/+archive/liferea-libindicate/+packages

This happens on a fully up-to-date Lucid x64 installation. Even if there's something wrong with the package, it would be nice if gdebi would give some useful output instead of crashing. Here's the trace:

michael@michael-desktop:~/Downloads$ gdebi ./liferea-data_1.7.4-2~llfsyncfix1+sikon8_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
  Traceback (most recent call last):
  File "/usr/bin/gdebi", line 83, in <module>
    if not debi.open(args[0]):
  File "/usr/lib/python2.6/dist-packages/GDebi/GDebiCli.py", line 86, in open
    if not self._deb.checkDeb():
  File "/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py", line 368, in checkDeb
    if not self.checkBreaksExistingPackages():
  File "/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py", line 283, in checkBreaksExistingPackages
    'depversion' : dep.version}
TypeError: not enough arguments for format string

Let me know if there's any more information that I can provide.