Internet Searches: Japanese characters not displayed correctly

Bug #550639 reported by Bao Tran on 2010-03-29
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

I cannot view Japanese searches correctly in GCStar. To reproduce this:

1) Create a new video game collection
2) do a video game search, say "gundam", using Amazon (JP)
3) See result with garbled name.

Once you select a search item though, the characters appear correctly within the main view. Saving and opening the collection is fine.

I have attached a screenshot to demonstrate what I am seeing.

I have even tried setting the "Language for non-unicode programs" to Japanese, but the problem persists. Japanese letters show up correctly in the main program regardless of this setting though, so I doubt this setting makes any difference at all for this program.

I first came across this bug while I was developing a new internet search plugin & model for Japanese PC Games. Thinking it could be just me, I tried the prepackaged internet search plugins that used Japanese and noticed the same problem. All of my plugins are updated as of this posting.

My Environment:
GCStar 1.50
Windows 7 x64


Bao Tran (bqtran) wrote :
tags: added: dialog i18n internationalization internet internetsearches japanese plugin search unicode
zombiepig (nyall-zombiepigs) wrote :

I can't duplicate this one while running gcstar under linux. Looks like it's a Windows-specific problem. I'll keep digging into it for you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers