Sporadic gconf error messages

Bug #848198 reported by Marc Deslauriers on 2011-09-12
290
This bug affects 69 people
Affects Status Importance Assigned to Milestone
gconf
Fix Released
Medium
gconf (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Since updating to Oneiric, evolution gives a gconf error message about once or twice a day. See the attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: evolution 3.1.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Mon Sep 12 15:26:22 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
SourcePackage: evolution
UpgradeStatus: Upgraded to oneiric on 2011-08-16 (27 days ago)

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

Actually, I am seeing this with other applications also, not just evolution. Reassigning to gconf.

affects: evolution (Ubuntu) → gconf (Ubuntu)
summary: - evolution gives sporadic gconf error messages
+ Sporadic gconf error messages
Marc Deslauriers (mdeslaur) wrote :

Similar issue in Bug #842648...

Marc Deslauriers (mdeslaur) wrote :

Similar issue also in Bug #831887

Marc Deslauriers (mdeslaur) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Pedro could you send that to GNOME?

Changed in gconf (Ubuntu):
assignee: nobody → Pedro Villavicencio (pvillavi)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=659835

Changed in gconf (Ubuntu):
assignee: Pedro Villavicencio (pvillavi) → nobody
status: Confirmed → Triaged
Changed in gconf:
importance: Undecided → Unknown
status: New → Unknown
Changed in gconf:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Could somebody try to get a "dbus-monitor --session > log" log and copy what happens when you get the issue?

Jamie Strandboge (jdstrand) wrote :

This happens to me as well, and seems to be whenever I use 'apt-get upgrade'. I'll look into this more and try to reproduce.

Brandon Snider (brandonsnider) wrote :

Four patches have appeared to deal with this issue:

https://bugzilla.gnome.org/attachment.cgi?id=199238
https://bugzilla.gnome.org/attachment.cgi?id=199239
https://bugzilla.gnome.org/attachment.cgi?id=199240
https://bugzilla.gnome.org/attachment.cgi?id=199241

I added them into the gconf scripts and built the binaries locally. So far, no error messages are appearing.

Stanley Bartlett (stanlume) wrote :

If this is the cure, then kindly explain how I "add them into the gconf scripts and build the binaries locally"? I do not know where I go to do this and how.

Thanks

Four patches have appeared to deal with this issue:

https://bugzilla.gnome.org/attachment.cgi?id=199238
https://bugzilla.gnome.org/attachment.cgi?id=199239
https://bugzilla.gnome.org/attachment.cgi?id=199240
https://bugzilla.gnome.org/attachment.cgi?id=199241

I added them into the gconf scripts and built the binaries locally. So far, no error messages are appearing.

Jeremy Bicha (jbicha) wrote :

Just a note that this bug is believed to break the workspaces feature in GNOME Shell as reported in bug 853582.

Gianvito Cavasoli (janvitus) wrote :

However, I have attached the log of dbus-monitor.

Brandon Snider (brandonsnider) wrote :

After using the patched version for a couple of days there are no error messages and no apparent ill effects, and bug 853582 doesn't happen.

iMac (imac-netstatz) wrote :

Upstream patches fixed this for me too.. happened every time evolution or gconf related package updates occurred.

Changed in gconf:
status: New → Fix Released
Bernhard Schmidt (berni) wrote :

I've created a PPA with a fixed package (all four patches applied), it fixes the gnome-shell issue for me.

https://launchpad.net/~berni/+archive/ppa

Use at your own risk, there is at least one other package for oneiric in there (multi-arch libxp). Download the packages manually and/or remove the repository after you have upgraded.

There is also an updated gconf version in the semi-official gnome-shell PPA at https://launchpad.net/~ricotz/+archive/testing , you might want to use that instead. A fixed upstream version (3.2.1) should be released soon according to the gnome-bugs bugtracker.

Jeremy Bicha (jbicha) on 2011-10-26
Changed in gconf (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Changed in gconf (Ubuntu Oneiric):
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha) on 2011-10-26
Changed in gconf (Ubuntu Oneiric):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in gconf (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody

Hello Marc, or anyone else affected,

Accepted gconf into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gconf (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Chow Loong Jin (hyperair) wrote :

Looks like it works. I just ran killall -HUP gconfd-2, and Banshee didn't go berserk.

I'm using the proposed version, so far so good

On Fri, Oct 28, 2011 at 03:37, Chow Loong Jin <email address hidden> wrote:

> Looks like it works. I just ran killall -HUP gconfd-2, and Banshee
> didn't go berserk.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (844881).
> https://bugs.launchpad.net/bugs/848198
>
> Title:
> Sporadic gconf error messages
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gconf/+bug/848198/+subscriptions
>

Jeremy Bicha (jbicha) on 2011-10-28
tags: added: verification-done
removed: verification-needed
Dmitry Shachnev (mitya57) wrote :

@Jeremy: after update to 3.2.2, I keep getting crashes in gconf_database_set_sources, see bug 882678 (which is a duplicate of private bug 882525). I think it's a regression and this version should not be moved to updates yet.

Martin Pitt (pitti) on 2011-10-29
tags: added: verification-failed
removed: verification-done
Gianvito Cavasoli (janvitus) wrote :

gconf 3.2.2 works for me, no more messages from Evolution or GNOME Shell.

Alejandro Arcos (arcosaf) wrote :

hi everyone,

after each update appear

 "GConf error: Configuration server couldn't be contacted: D-BUS error: Method "Set" with signature "s(ib)" on interface "org.gnome.GConf.Database" doesn't exist"

I can help

Mdavies5 (mdavies5) wrote :

At the risk of duplication I also get the following message in Oneiric. After logging on, running update, opening Evolution. I then ran a backup and the message kept appearing. I eventually had 9 windows to close:
GConf error: Configuration server couldn't be contacted: D-BUS error: Method "Set" with signature "s(ii)" on interface "org.gnome.GConf.Database" doesn't exist

Marc Deslauriers (mdeslaur) wrote :

The regression was fixed in 3.2.3. The package in proposed needs to be updated.

Jeremy Bicha (jbicha) wrote :

I packaged 3.2.3 now; just waiting for it be accepted into oneiric-proposed. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.3-0ubuntu1

---------------
gconf (3.2.3-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fixes gconf crasher regression in 3.2.2 (LP: #882525)

gconf (3.2.2-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf errors affecting GNOME Shell & Evolution, especially
      seen after a system upgrade (LP: #848198)
    - Build fix for -Werror=format-securiy
    - Avoid crash when there is no reply to messages in
      gconf_engine_notify_remove
    - Clean-up ORBit vs DBus logic
  * debian/watch: Removed extra \d
 -- Jeremy Bicha <email address hidden> Tue, 01 Nov 2011 08:48:09 -0400

Changed in gconf (Ubuntu):
status: Triaged → Fix Released
Quinta Helmer (qhelmer) wrote :

After not having seen the error message for a couple of weeks it just popped up again:
GConf error: Configuration server couldn't be contacted: D-BUS error: Method "LookupExtended" with signature "ssb" on interface "org.gnome.GConf.Database" doesn't exist

I use Ubuntu Onieric and have installed all updates until now. How do I check which version of gconf I run?

Jeremy Bicha (jbicha) wrote :

Quinta, run apt-cache policy gconf2 to see which version is installed.

Hello Marc, or anyone else affected,

Accepted gconf into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

The fix still works for me with the new version.

tags: added: verification-done
removed: verification-needed
Quinta Helmer (qhelmer) wrote :

I still get the error after updating to gconf 3.2.3-0ubuntu0.1. It happens only the first time I do something in evolution after installing updates (i.e. once a day for me).

tags: added: verification-failed
removed: verification-done
Sebastien Bacher (seb128) wrote :

if the fix works for some users and doesn't break anything for others it should maybe not be failed there

Jeremy Bicha (jbicha) wrote :

Quinta, did you try rebooting before testing if the proposed gconf works?

Quinta Helmer (qhelmer) wrote :

Nope, I did not reboot (I try to do that as little as possible). I am willing to give that a try, but we will have to wait till the next evolution or gconf related update to know if it works.

Jeremy Bicha (jbicha) wrote :

You can get a gconf trigger by installing or uninstalling any app that uses gconf. Here's one example:

sudo apt-get remove gconf-editor
sudo apt-get install gconf-editor

I suggested you reboot because I still had the bug until I rebooted. There might be another way to completely stop and start gconf but rebooting was simple.

Martin Pitt (pitti) on 2011-11-07
tags: added: verification-done
removed: verification-failed
Quinta Helmer (qhelmer) wrote :

I have rebooted now, but I can still trigger the error message by reinstalling gconf-editor as in Jeremy's example and doing anything in evolution (for example opening a message) after that.

I let you decide if it is necessary to change the tags.

This error affects me every time (or at least almost) that i check mail in evolution. It prompts a message "GConf error: Configuration server couldn't be contacted: D-BUS error: Method "LookupExtended" with signature "ssb" on interface "org.gnome.GConf.Database" doesn't exist"

Regards,

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.3-0ubuntu0.1

---------------
gconf (3.2.3-0ubuntu0.1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf crasher regression in 3.2.2 (LP: #882525)

gconf (3.2.2-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf errors affecting GNOME Shell & Evolution, especially
      seen after a system upgrade (LP: #848198)
    - Build fix for -Werror=format-securiy
    - Avoid crash when there is no reply to messages in
      gconf_engine_notify_remove
    - Clean-up ORBit vs DBus logic
  * debian/watch: Removed extra \d
 -- Jeremy Bicha <email address hidden> Tue, 01 Nov 2011 08:48:09 -0400

Changed in gconf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.