android builds failing due to gcc 4.8 failing to compile ffmpeg

Bug #1189357 reported by Naresh Kamboju on 2013-06-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Critical
Bernhard Rosenkraenzer
Linaro GCC
New
Undecided
Unassigned

Bug Description

Following big.LITTLE MP builds failed:
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=317
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=316
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=315
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=314
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=313

seems to be problem with gcc 4.8 issue
https://android-build.linaro.org/jenkins/job/linaro-android_vexpress-linaro-mp/317/parsed_console/?

/mnt/jenkins/workspace/linaro-android_vexpress-linaro-mp/build/external/ffmpeg/libavcodec/arm/dca.h:36:5: error: can't find a register in class 'CORE_REGS' while reloading 'asm'
/mnt/jenkins/workspace/linaro-android_vexpress-linaro-mp/build/external/ffmpeg/libavcodec/arm/dca.h:36:5: error: 'asm' operand has impossible constraints
make[1]: *** [libavcodec/dca.o] Error 1
make: *** [ffmpeg] Error 2

vishal (vishalbhoj) on 2013-06-10
summary: - bL MP android build (317/316/315/314/313) failed
+ android builds failing due to gcc 4.8 failing to compile ffmpeg
Changed in linaro-android:
importance: Undecided → Critical
assignee: nobody → Bernhard Rosenkraenzer (berolinux)
milestone: none → 13.06

Changing to "Fix Committed" in linaro-android (we've updated ffmpeg with different code), but leaving it open on the gcc-linaro side (why gcc 4.7 could find registers to work with and 4.8 can't deserves some investigation).

Changed in linaro-android:
status: New → Fix Committed
vishal (vishalbhoj) wrote :
Changed in linaro-android:
status: Fix Committed → In Progress
Naresh Kamboju (naresh-kamboju) wrote :

following build also failed:
ffmpeg seems to still fail to compile on android-build:
https://android-build.linaro.org/jenkins/job/linaro-android-restricted_vexpress-linaro-iks/251/parsed_console/?

Interesting, I can't reproduce this locally...
Relevant failure seems to be:

arm-linux-androideabi-gcc is unable to create an executable file.
C compiler test failed.

Maybe PATH is not getting set right, looking

Found a way to reproduce locally.

Fixed

(on android side, still leaving gcc open)

Changed in linaro-android:
status: In Progress → Fix Committed

I have downloaded big.LITTLE IKS test images from this build [1] which is using tool chain [2] and tested on vexpress-linaro build [3]

ffmpeg test failed. due to below reason
root@android:/data/local # ffmpeg
soinfo_link_image(linker.cpp:1635): could not load library "libavfilter.so.2" ne
eded by "ffmpeg"; caused by soinfo_link_image(linker.cpp:1635): could not load l
ibrary "libavformat.so.54" needed by "libavfilter.so.2"; caused by soinfo_link_i
mage(linker.cpp:1635): could not load library "libavcodec.so.54" needed by "liba
vformat.so.54"; caused by soinfo_relocate(linker.cpp:975): cannot locate symbol
"__popcountsi2" referenced by "libavcodec.so.54"...CANNOT LINK EXECUTABLE

Summary ..
Total Tests = 30
Tests Passed = 22
Tests Failed = 8 [ [a] 4 perf test failed + [b] 4 ffmpeg test failed]

[a] Perf broken on linux-linaro 3.10.x kernel
 https://bugs.launchpad.net/linaro-big-little-system/+bug/1183821

[b] android builds failing due to gcc 4.8 failing to compile ffmpeg
https://bugs.launchpad.net/linaro-android/+bug/1189357

[1] https://android-build.linaro.org/builds/~linaro-android-restricted/test-private-test-suite/#build=60

- tests_userdata.tar.bz2
- tests_system.tar.bz2

[2]TOOLCHAIN_URL=https://releases.linaro.org/latest/components/toolchain/binaries/gcc-linaro-arm-linux-gnueabihf-4.8-2013.05_linux.tar.bz2
TOOLCHAIN_TRIPLET=arm-linux-gnueabihf-

[3] https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro/#build=7

[4] TARGET_TOOLS_PREFIX=prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.8-linaro/bin/arm-linux-androideabi-
TOOLCHAIN_TRIPLET=arm-linux-androideabi

Test execution log:
[4] https://pastebin.linaro.org/view/0ee0b1eb

ffmpeg log:
[5] https://pastebin.linaro.org/view/762e0bb0

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.