Abort trap 6 on Mac OSX

Bug #1655778 reported by Scott Shawcroft on 2017-01-11
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNU Arm Embedded Toolchain
Undecided
Unassigned

Bug Description

Hi all,
I'm running 7.12.0.20161204-git on the latest Mac OSX Sierra beta on the latest Macbook Pro and am getting crashes with "Abort trap: 6" as the only info. I am using the prebuilt binaries from https://developer.arm.com/open-source/gnu-toolchain/gnu-rm.

Below is an example session with verbose and complaints turned on. Its sporadic where it happens. I've seen it after the target line, after a continue to a breakpoint and on backtrace. Let me know what other information you need. Thanks!

$ bin/arm-none-eabi-gdb ~/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf
GNU gdb (GNU Tools for ARM Embedded Processors) 7.12.0.20161204-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-apple-darwin10 --target=arm-none-eabi".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf...done.
(gdb) set verbose on
(gdb) set complaint 10000
(gdb) tar ext :2331
Remote debugging using :2331
warning: platform-specific solib_create_inferior_hook did not load initial shared libraries.
unexpected overlap between:
 (A) section `.text' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x32968)
 (B) section `*COM*' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x0).
Will ignore section B...unexpected overlap between:
 (A) section `.text' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x32968)
 (B) section `*UND*' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x0).
Will ignore section B...unexpected overlap between:
 (A) section `.text' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x32968)
 (B) section `*ABS*' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x0).
Will ignore section B...unexpected overlap between:
 (A) section `.text' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x32968)
 (B) section `*IND*' from `/Users/tannewt/repos/circuitpython/atmel-samd/build-metro_m0_flash/firmware.elf' [0x0, 0x0).
Will ignore section B...Reading in symbols for rgb_led_status.c...done.
incomplete CFI data; unspecified registers (e.g., r0) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r1) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r2) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r8) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r9) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r10) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r11) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r12) at 0x1ac8a...incomplete CFI data; unspecified registers (e.g., r0) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r1) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r2) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r3) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r8) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r9) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r10) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r11) at 0x1a026...incomplete CFI data; unspecified registers (e.g., r12) at 0x1a026...color_brightness (color=color@entry=16128, Abort trap: 6

Tejas Belagod (belagod-tejas) wrote :

Thanks for the bug report. We're looking at this right now.

Are you able to reproduce it?

Girts F (girts-folkmanis) wrote :

I'm getting weird crashes with the new version too:

$ ./arm-none-eabi-gdb -ex 'mem'
GNU gdb (GNU Tools for ARM Embedded Processors) 7.12.0.20161204-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-apple-darwin10 --target=arm-none-eabi".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
fish: './arm-none-eabi-gdb -ex 'mem'' terminated by signal SIGABRT (Abort)

This is on OS X 10.11.6, with the gcc-arm-none-eabi-6_2-2016q4 bundle from arm.

Michal Vanco (michal-vanco) wrote :

Same here:

arm-none-eabi-gdb -ex 'mem'
GNU gdb (GNU Tools for ARM Embedded Processors) 7.12.0.20161204-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-apple-darwin10 --target=arm-none-eabi".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
Abort trap: 6

Running on OS X 10.12.2.

Liviu Ionescu (ilg) wrote :

The problem is still present in the released GCC 6.2:

$ arm-none-eabi-gdb --interpreter=mi2 --nx
=thread-group-added,id="i1"
~"GNU gdb (GNU Tools for ARM Embedded Processors) 7.12.0.20161204-git\n"
~"Copyright (C) 2016 Free Software Foundation, Inc.\n"
~"License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>\nThis is free software: you are free to change and redistribute it.\nThere is NO WARRANTY, to the extent permitted by law. Type \"show copying\"\nand \"show warranty\" for details.\n"
~"This GDB was configured as \"--host=x86_64-apple-darwin10 --target=arm-none-eabi\".\nType \"show configuration\" for configuration details."
~"\nFor bug reporting instructions, please see:\n"
~"<http://www.gnu.org/software/gdb/bugs/>.\n"
~"Find the GDB manual and other documentation resources online at:\n<http://www.gnu.org/software/gdb/documentation/>.\n"
~"For help, type \"help\".\n"
~"Type \"apropos word\" to search for commands related to \"word\".\n"
(gdb)
1-gdb-set charset ISO-8859-1
Abort trap: 6

similarly:

$ arm-none-eabi-gdb --interpreter=mi2 --nx
...
(gdb)
1-gdb-set language auto
Abort trap: 6

since the Eclipse debug plug-ins always issue these commands, GDB 7.12 cannot be used with Eclipse at all.

running on macOS 10.12.2 (16C67)

regards,

Liviu Ionescu

Liviu Ionescu (ilg) wrote :

can someone confirm this bug?

it is pretty urgent, as it is now, 6.2 cannot be used on macOS.

Hi Liviu,

We are aware of a GDB crashing on MacOS when an invalid command is entered. Is that what you are experiencing? We shall provide a fixed GDB with regards to this bug shortly.

Liviu Ionescu (ilg) wrote :

> ... when an invalid command is entered

I don't think the commands used by Eclipse CDT are invalid, they were quite valid in previous GDB versions.

Liviu

sfc (sfc-0) wrote :

Same here.

arm-none-eabi-gdb version 7.12.0.20161204-git
macOS Sierra 10.12.3
eclipse 4.6.2
CDT 9.2.0.201612061315
GNU ARM Eclipse OpenOCD debug plugin 4.1.2.201701141320
openocd 0.10.0

Any "invalid" command will crash gdb with "Abort trap: 6".
The GNU ARM Eclipse plugin issues following gdb commands:

813,387 2-gdb-show language
813,388 2^done,value="auto"
813,389 (gdb)
813,392 3-data-evaluate-expression "sizeof (void*)"
813,393 3^done,value="4"
813,393 (gdb)
813,394 4-gdb-set language auto

Then gdb crashed.
Same versions of gdb, eclipse, cdt, gnuarmeclipse-plugin are working well on a Ubuntu 16.10 machine (using openocd 0.9) without any crash.

sfc (sfc-0) wrote :

Tried gdb from gcc-arm-none-eabi-5_4-2016q3-20160926-mac, this works.

Changed in gcc-arm-embedded:
status: New → Fix Committed
Changed in gcc-arm-embedded:
status: Fix Committed → Fix Released
Liviu Ionescu (ilg) wrote :

version 6.3, released on Feb 23, seems ok.

Alfonso Rizo-Patron (alrizopa) wrote :

Running MacOS High Sierra (10.13.6) on a Mac Pro (2013) and I am getting 'abort trap: 6' when running *any* RCS command (res, or ci, or log, etc.) that runs OK under "El Capitan" (Mac OS X 10.11.6).

The executables are the same --version in both MacOS 10.13.6 as in 10.11.6:

sh-3.2# rcs --version
rcs (GNU RCS) 5.9.1
Copyright (C) 2010-2013 Thien-Thi Nguyen
Copyright (C) 1990-1995 Paul Eggert
Copyright (C) 1982,1988,1989 Walter F. Tichy, Purdue CS
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> ... etc.

Ideas?

Alfonso Rizo-Patron (alrizopa) wrote :

Looks like I was picking up the executables from /opt/local/bin which is not part of the MacOS distribution, that's why the files didn't change with the OS upgrade.
Probably need an update from macports or similar.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers