ICE with empty FIQ handler

Bug #1454506 reported by Thomas Preud'homme on 2015-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Arm Embedded Toolchain
Medium
Thomas Preud'homme

Bug Description

Compiling the following test case results in internal compiler error on -O0 (on -O1 and above it works)
void r_fiq_handler(void) __attribute__((interrupt ("FIQ")));

void r_fiq_handler(void)
{
}

Error message:

test.c: In function 'r_fiq_handler':
test.c:5:1: error: insn does not satisfy its constraints:
 }
 ^
(insn/f 12 11 13 (set (reg/f:SI 13 sp)
        (plus:SI (reg/f:SI 11 fp)
            (const_int 4 [0x4]))) test.c:5 4 {*arm_addsi3}
     (expr_list:REG_CFA_ADJUST_CFA (set (reg/f:SI 13 sp)
            (plus:SI (reg/f:SI 11 fp)
                (const_int 4 [0x4])))
        (nil)))
test.c:5:1: internal compiler error: in note_invalid_constants, at config/arm/ar
m.c:16695
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

This can be reproduces with 4.8 and 4.9 series, it works in 4.7.

Can this be fixed?

Changed in gcc-arm-embedded:
status: New → Confirmed

Confirmed on 4.9 2015Q1 release. The bug seems to be fixed for trunk.

Changed in gcc-arm-embedded:
status: Confirmed → In Progress
Changed in gcc-arm-embedded:
status: In Progress → Fix Committed
Changed in gcc-arm-embedded:
importance: Undecided → Medium
assignee: nobody → Thomas Preud'homme (thomas-preudhomme)
milestone: none → 6-2016-q4-major
Changed in gcc-arm-embedded:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions