no stdint.h file error

Bug #1326540 reported by Cerem Cem ASLAN on 2014-06-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Arm Embedded Toolchain
Undecided
Terry Guo
Tony Wang (wangzheyu1989) wrote :

Hi Cerem,

I tried the gcc version: gcc version 4.8.3 20140228 (release) [ARM/embedded-4_8-branch revision 208322] (GNU Tools for ARM Embedded Processors) to build some samples in the Chibios, but it works fine. Can you share your toolchain version so that we can reproduce it?

Hi Cerem Cem,

Have you libc6-dev installed on your system?

Best regards,

Thomas

Sorry, scratch that. The file should be included in our toolchain in /usr/arm-none-eabi/include/stdint.h. If you don't have that file it probably means you installed the wrong toolchain (there is another toolchain with the same name in the repository). What does apt-cache policy gcc-arm-none-eabi gives you?

Cerem Cem ASLAN (ceremcem-2) wrote :

arm-none-eabi-gcc (4.8.2-16+8) 4.8.2

gcc-arm-none-eabi:
  Installed: 4.8.2-16+8
  Candidate: 4.8.2-16+8
  Version table:
 *** 4.8.2-16+8 0
        500 http://ftp.tr.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status

sudo apt-get install libc6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6-dev is already the newest version.
libc6-dev set to manually installed.

Cerem Cem ASLAN (ceremcem-2) wrote :

Thank you for your kind responses. I have the feeling that I should need to remove the debian package and install manually.

Terry Guo (terry.guo) wrote :

Seems to me that you are using tool chain released by Ubuntu, not by us. Please refer to https://bugs.launchpad.net/gcc-arm-embedded/+bug/1309060.

Cerem Cem ASLAN (ceremcem-2) wrote :

I downloaded gcc-arm-none-eabi-4_8-2014q1 from this site and it worked just fine.

Thank you.

Terry Guo (terry.guo) on 2014-06-06
Changed in gcc-arm-embedded:
assignee: nobody → Terry Guo (terry.guo)
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers