The package does not contain indexes for Ubuntu 13.10 (Saucy)

Bug #1244060 reported by NetBUG on 2013-10-24
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNU Arm Embedded Toolchain
Medium
Terry Guo

Bug Description

The indexes do not contain files for Ubunto 13.10 (Saucy Salamander).
W: Failed to fetch http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu/dists/saucy/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu/dists/saucy/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

One can easily fix it by editing /etc/apt/sources.list.d/terry_guo-gcc-arm-embedded-saucy.list to
deb http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu raring main
# deb-src http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu raring main

but it would be better (e.g. for probable compatibility issues) to make a separate repo. It's completely OK to fill it with symlinks unless somethings breaks.

Changed in gcc-arm-embedded:
status: New → Confirmed
Terry Guo (terry.guo) on 2013-10-25
Changed in gcc-arm-embedded:
importance: Undecided → Wishlist
assignee: nobody → Terry Guo (terry.guo)
Terry Guo (terry.guo) wrote :

This tool chain is released before the release of 13.10. Will discuss this request and see if we can support it in next release.

Thank you!

Seems that currenty there is no need to do anything special to support it,
after I installed it manually, it just works.
I've compiled ~ten revisions of my code (with ChibiOS) for STM32F4 without
any issues.

2013/10/25 Terry Guo <email address hidden>

> This tool chain is released before the release of 13.10. Will discuss
> this request and see if we can support it in next release.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1244060
>
> Title:
> The package does not contain indexes for Ubuntu 13.10 (Saucy)
>
> Status in GNU Tools for ARM Embedded Processors:
> Confirmed
>
> Bug description:
> The indexes do not contain files for Ubunto 13.10 (Saucy Salamander).
> W: Failed to fetch
> http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu/dists/saucy/main/binary-amd64/Packages 404 Not Found
>
> W: Failed to fetch http://ppa.launchpad.net/terry.guo/gcc-arm-
> embedded/ubuntu/dists/saucy/main/binary-i386/Packages 404 Not Found
>
> E: Some index files failed to download. They have been ignored, or old
> ones used instead.
>
> One can easily fix it by editing
> /etc/apt/sources.list.d/terry_guo-gcc-arm-embedded-saucy.list to
> deb http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu raring
> main
> # deb-src http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubunturaring main
>
> but it would be better (e.g. for probable compatibility issues) to
> make a separate repo. It's completely OK to fill it with symlinks
> unless somethings breaks.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gcc-arm-embedded/+bug/1244060/+subscriptions
>

--
:)
Cheers,
Urzhumtsev Oleg

Terry Guo (terry.guo) wrote :

Thanks for sharing this tip and confirming that it works. Theoretically we should enable tool chain PPA for 13.10 just like what we did for 12.04/13.04.

Terry Guo (terry.guo) on 2013-11-27
Changed in gcc-arm-embedded:
status: Confirmed → Fix Committed
milestone: none → 4.8-2013-q4-major
Terry Guo (terry.guo) wrote :

The texinfo related packages in 13.10 are newer version which prevent "make pdf" steps in our build scripts. GCC and GDB have updated their .texinfo files, but the one in newlib hasn't been updated. So we postpone the PPA for 13.10 to next release.

Changed in gcc-arm-embedded:
status: Fix Committed → Confirmed
milestone: 4.8-2013-q4-major → 4.8-2014-q2-update
Joey Ye (jinyun-ye) on 2014-02-28
Changed in gcc-arm-embedded:
status: Confirmed → In Progress
milestone: 4.8-2014-q2-update → 4.8-2014-q1-update
importance: Wishlist → Medium
Davi Murca Viotto (viottodavi) wrote :

It's a good news to me.

Sam Lin (itrs-lin) wrote :

please also update packages to trusty (14.04 LTS).
thanks

Terry Guo (terry.guo) on 2014-03-31
Changed in gcc-arm-embedded:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions