Error en linea de comando Banshee

Bug #786694 reported by Kitzune-1517 on 2011-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GatoScript
Medium
Raúl Soriano
Estable
Medium
Raúl Soriano

Bug Description

1. Xchat 2.8.8
2.Linux Mint 11 RC Katya
3.GatoScript 1.3
Traceback (most recent call last):
   File "/home/zorro/.xchat2/gatoscript/modulos/media.py", line 256, in media_cb
     tiempo = int(informacion[2].split(": ")[1].split(",")[0])
 ValueError: invalid literal for int() with base 10: '225.143'
* escuchando :Unknown command

description: updated
Changed in gatoscript:
assignee: nobody → Kitzune-1517 (kitzune-1517)
Raúl Soriano (gatoloko) wrote :

It's failing to parse the song's length. Banshee seems to use locale provided separator for decimals, and my script is trying to split a string with a "," where there is a "." in your case.

You assigned the bug resolution to yourself, do you really plan to fix it or was it a mistake?

Changed in gatoscript:
importance: Undecided → Medium
status: New → Triaged
tags: added: media
Kitzune-1517 (kitzune-1517) wrote :

I never try to fix this error
This error came out recently put the script in xchat

If the problem is ¨.¨ then i change this ¨.¨ for ¨,¨

Kitzune-1517 (kitzune-1517) wrote :

sorry sorry
change ¨,¨ for ¨.¨

is it correct?

Kitzune-1517 (kitzune-1517) wrote :

Change (¨,¨) with (¨.¨)
Gato please fix this error in the next release of the script

Changed in gatoscript:
status: Triaged → Fix Committed
Raúl Soriano (gatoloko) on 2011-05-24
Changed in gatoscript:
assignee: Kitzune-1517 (kitzune-1517) → Raúl Soriano (gatoloko)
status: Fix Committed → Triaged
Raúl Soriano (gatoloko) wrote :

Since I'm the one fixing this, I'm the "assignee". Don't assign yourself bugs you don't plan to fix, and since you didn't commit a fix, you shouldn't change the status to "Fix committed". Messing with those things may confuse people and prevent the real fixes.

Kitzune-1517 (kitzune-1517) wrote :

Ok sorry for this

Raúl Soriano (gatoloko) on 2011-05-24
Changed in gatoscript:
status: Triaged → Fix Committed
Raúl Soriano (gatoloko) on 2011-06-02
Changed in gatoscript:
milestone: none → 1.4
Raúl Soriano (gatoloko) on 2011-06-09
Changed in gatoscript:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers