GASP hangs up after begin_graphics()

Reported by allen daniell on 2010-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GASP Core
Undecided
Unassigned

Bug Description

                    i am using ubuntu 9.10, python 2.6 , and i am not sure as to the gasp version.i installed using the synaptic-package manager.the package manager use the ppa to install. i believe it is 0.3.3. i looked in all my python folders and i see the gasp folders, but none of them state what version. the reason i think it is 0.3.3 is because i have a folder named
gasp-0.3.3.egg-info.
                the problem is when ever i use the line "begin_graphics()" in any context, and i run the script in the shell the only thing i get is a small window box come up in the middle of the shell window. the box is blank and has the title "KILL". there is no way to close this "KILL box" and i cant stop or close the shell window either. the only way that i have found to get rid of it is to logout and then back in. if any one knows how to fix this please enlighten me.

allen daniell (allen-daniell) wrote :

well guys i figured it out!!!!

the problem is the idle. it is written in Tkinter. that mean that when we use "begin_graphics()" the mainloop then conflicts with the tk() mainLoop(). i learned this reading a great book called "wxPython in Action". it was explaining about wxPython, but i was able to see the paralle with GASP. so to try it out i cut and paste code from "How to Think Like a Computer...." in to the main IDE that i now use, SPE(Stani's Python Editor). guess what?
 it worked!!!! i believe that this is the root of many of the problems that many of us are having with GASP. so try to use a Different IDE that is not written in TKinter and see what happens. hope this helps somone else.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers