GASP crashes after begin_graphics()

Bug #162089 reported by Heath Matlock on 2007-11-11
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GASP Core
High
Unassigned

Bug Description

Using Windows and after importing GASP and all its sub-modules by typing

from gasp import *

and then typing

begin_graphics()

a blank window pops up, but doesn't display anything. After awhile, it's recognized as not
responding. Not sure if it would help or not, I tried

from pygame import *

and still got the same results. Did the exact same procedures with the latest nightly build a few seconds ago.

Heath Matlock (heathmatlock) wrote :

Two clarifications, pygame was imported before gasp, and the results for the nightly build were the same as previously stated.

Luke Faraone (lfaraone) wrote :

Duplicated bug in Vista.
Even if code is executed, it still hangs at the end of execution.

Changed in gasp:
status: New → Confirmed
Luke Faraone (lfaraone) wrote :

Example code snippit:
http://paste.ubuntu-nl.org/44194/

Matthew Gallagher (mattva01) wrote :

This might have something to do with end_graphics() current behavior. I

devolve (devolve) wrote :

This exact same thing is happening to me. gasp is completely useless this way. This is a real shame because I've been learning python and have been pretty excited about the entire concept. After reading an e-book that out-of-nowhere starts talking about using gasp (with no suggestion as to how to even go about getting it), and then after finally getting gasp only to find out that I need pygame installed in order to run gasp (this befuddles me as to why they're not packaged together or at least a mention made of this)..............I then get the gasp window hanging and eventually crashing.

I'm really sorry, I'm just venting because I just spent four hours trying to get this stuff up and running and now the only thing I have is an open ticket that doesn't seem to be much of a high priority. If people want new people coming to python things like this need to be addressed. I'm on the verge of giving up. Help.

Luke Faraone (lfaraone) on 2008-06-27
Changed in gasp-code:
importance: Undecided → High
milestone: none → 0.2
Matthew Gallagher (mattva01) wrote :

Could I get a clarification ? Are all of you on Microsoft platforms(particularly vista)

I use Windows XP and have the exact same problem

Just took a closer look at my problem. It begins to act like it will work for a little while, but before it can receive input, it becomes unresponsive.

chflow (sevenflow-digital) wrote :

Having the same problem. I would love to continue this tutorial, but it says it's going to make extensive use of your tools, and I can't get them to work properly. :(

chflow (sevenflow-digital) wrote :

I solved this issue on my system by following these instructions:

3. Microsoft Windows
An installer is avalible for Windows, but it is currently not up to date with the latest version of GASP. In the mean time, you can download the source and untar it (using 7zip or bzip2) to your site-packages directory (defaults are given below).

Python2.5: C:\Python25\lib\site-packages
4. Use the Source, Luke.

The source can be downloaded from dev.laptop.org.

In short, I am an idiot and should read the installation instructions instead of assuming I know what I'm doing. Thanks for making a such a great learning tool.

chflow (sevenflow-digital) wrote :

Actually, it seems that didn't really do anything. It seems that I can get the canvas to work as long as i begin_graphics() and do whatever commands I have, but only so long as I don't switch to another window. I have to stay in the IDLE editor. The second I actually click on the canvas, or switch to my firefox window, it instantly becomes unresponsive. Windows XP Pro, by the way.

lautzutao (lautzutao) wrote :

Same issue, as long as I don't switch from the IDLE window to any other window GASP works properly. As soon as I highlight another window GASP crashes.

John Rockstad (rock-john) wrote :

I've experienced similar behavior running GASP on OS X, with a bit of a twist though. After initializing GASP with begin_graphics() it appears to start up as normal for a few seconds, then I get the "beachball" and OS X reports "Application Not Responding." It has all the appearances of hanging, but here's the interesting part: I'm still able to interact with GASP as normal even after this occurs, i.e., if I enter "Circle((x, y), z)" or such it will display the shape as is expected.

This has been tested with the latest versions of GASP and pygame under Python 2.5.2 on OS X 10.4.11.

gjp (mrdata40) wrote :

I've managed to work around the problem described above by running Python from the IDLE GUI. (I'm running on a ThinkPad X32 under XP Pro.) True, the GASP screen still becomes unresponsive when I Alt-Tab to another wiindow. However, when I execute begin_graphics() from the IDLE command prompt, the GASP window again becomes responsive (although anything I've drawn on the screen gets cleared).

I've also discovered that the GASP code in the Elkner et al tutorial that is intended to run in a .py script executes just fine. For example, the first code snippet in "Chapter 8 -- Case Study: Catch" (http://openbookproject.net/thinkCSpy/), when saved into a .py file and invoked from the DOS prompt, runs just fine.

Luke Faraone (lfaraone) wrote :

Hi,

Can you test this out in the latest version of GASP?

Changed in gasp-code:
status: Confirmed → Incomplete
Luke Faraone (lfaraone) on 2009-08-18
Changed in gasp-code:
status: Incomplete → Invalid
allen daniell (allen-daniell) wrote :

hi. i am having the problem ,also. but that is evident. the difference is i am running ubuntu 9.10. and when ever i use begin_graphics() i get a small window with the title "KILL". the only way to get the window to go away is to logout then back in. i have no idea how to fix it!!!!!

Luke Faraone (lfaraone) wrote :

Allen,

Please report a separate bug for your issue, and describe the method in which you start gasp, the GASP version, etc.

allen daniell (allen-daniell) wrote :

well guys i have something for you to try. most of you are running windows so i am not sure if this same fix will work for you but you can try it.

this is so simple that it is retarded. the problem is the IDLE. because it is written in Tkinter the IDLE itself is maintained by a MainLoop(). and Begin_Graphics() is also a MainLoop, so the two end up having a conflict. so the solution is to use and IDE that is not writen in Tkinter. for some reason IDE's written in wxPython don't have this problem even though it uses a main loop also. the IDE that i use now is called SPE(Stani's Python Editor). i am not sure if it will run on window or not. you can also try Netbeans IDE. it is a very good one, too.you'll have to get the python plug-ins for it. it is really a Java IDE, but once you get the Python plug-ins it is one of the best. and i know it runs on windows.

so i hope this helps some. and good luck.

Changed in gasp-core:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions