Header and popup menus don't handle rotation correctly

Bug #1369506 reported by Sebastien Bacher
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Unassigned
gallery-app
Fix Released
High
Ugo Riboni
ubuntu-ui-toolkit (Ubuntu)
Fix Released
Undecided
Unassigned
Vivid
Fix Released
Undecided
Unassigned

Bug Description

Using rtm-40 on krillin
- click on a photo
- open one of the menu of the headerbar
- rotate the device

the popdown menu gets misplaced, rotating back the device in the previous orientation doesn't bring it back where it was either

Related branches

Revision history for this message
Sebastien Bacher (seb128) wrote :

that's also an issue with the popup menu on the album view
- create an album
- rotate the screen it landscape
- press the album for some seconds

the menu opens in the wrong direction and over the album image

summary: - Header menus don't handle rotation correctly
+ Header and popup menus don't handle rotation correctly
Changed in gallery-app:
importance: Undecided → High
Bill Filler (bfiller)
tags: added: rtm14 touch-2014-10-09
Changed in gallery-app:
assignee: nobody → Ugo Riboni (uriboni)
Revision history for this message
Ugo Riboni (uriboni) wrote :
Revision history for this message
Tim Peeters (tpeeters) wrote :

We will close the popovers on rotation, see https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1375837

Seb128's issue is a separate bug, because there the popover is opened after rotating. Please report a separate bug for that.

Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in gallery-app:
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

unduplicating due to previous comment, the album view has the popup wrong even without rotation after opening

Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision 1268, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Zoltan Balogh (bzoltan)
Changed in ubuntu-ui-toolkit:
milestone: none → 10.09
Ugo Riboni (uriboni)
Changed in gallery-app:
status: Confirmed → Fix Committed
Ugo Riboni (uriboni)
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in gallery-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers