use libthumbnailer for gallery thumbnails

Bug #1221968 reported by Loïc Minier
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gallery-app
Fix Released
Critical
Ugo Riboni
gallery-app (Ubuntu)
Fix Released
Critical
Ugo Riboni
thumbnailer (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Hi,

Would be good to port from GStreamer 0.10 to 1.0. QtMultimedia + media-app ports are underway and we'll drop the PK backend soon.

Cheers,

Related branches

Revision history for this message
Loïc Minier (lool) wrote :

I've attached a branch with an attempt to port to GSt 1.0.

Main things I had to change:
* GstBuffers are now wrapped in GstSamples
* can't filter caps
* convert-frame is now convert-sample
* need to map/unmap buffers with GstMapInfo before ref-ing the data

This needs to be fixed so that QImage has a wrapper around GstMapInfo + GstBuffer rather than just GstBuffer; I did add an explicit GstBuffer ref, but that's not enough.

Sadly, I couldn't test this (but it built); camera-app doesn't record videos for me with latest system image on mako and doesn't work on grouper; I also tried to push a .mp4 file under Pictures on mako and on my desktop, but for some reason I never see the thumbnail generation kick in -- any idea?

Thanks!

Revision history for this message
Günter Schwann (schwann) wrote :

Camera video recording got broken due the new audio stack (and won't be fixed for 13.10).
You can test it locally, if you name the video file "video20130906_0001.mp4", so gallery assumes it's a camera recorded video.

Revision history for this message
Loïc Minier (lool) wrote :

BTW I got the camera-app to scan files, and now that I could test things I could see that my patch is completely broken, so please ignore :-)

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Confirming and marking as critical as we only want to depend on gst1.0 at the 13.10 release.

Changed in gallery-app:
status: New → Confirmed
importance: Undecided → Critical
Changed in touch-preview-images:
status: New → Confirmed
importance: Undecided → Critical
Revision history for this message
Günter Schwann (schwann) wrote :

lool: the patch looks ok, but it seem videos recorded by android don't work. The totem-video-thumbnailer has the same problem

Revision history for this message
Ricardo Salveti (rsalveti) wrote : Re: [Bug 1221968] Re: GStreamer 1.0 port

On Wed, Sep 18, 2013 at 10:56 AM, Günter Schwann
<email address hidden> wrote:
> lool: the patch looks ok, but it seem videos recorded by android don't
> work. The totem-video-thumbnailer has the same problem

We won't support video recording for 13.10, so we might still use this change.

Revision history for this message
Loïc Minier (lool) wrote : Re: GStreamer 1.0 port

The patch is NOT ok :-) I know I get gst warnings when running this on my desktop and it still has a TODO.

Jim said he had to develop a similar piece of thumbniliing code for mediaplayer-app in the coming days, and he thought it would be easy to copy-paste the gst bits into gallery-app when he is done.

@Jim: is it ok if I assign this to you?

Changed in gallery-app (Ubuntu):
status: New → Confirmed
assignee: nobody → Jim Hodapp (jhodapp)
Changed in gallery-app:
assignee: nobody → Jim Hodapp (jhodapp)
Revision history for this message
Jim Hodapp (jhodapp) wrote :

It's ok for now. If I end up not being the right person, I'll make sure it gets assigned to someone else.

Jim Hodapp (jhodapp)
summary: - GStreamer 1.0 port
+ GStreamer 1.0 port of video playback
summary: - GStreamer 1.0 port of video playback
+ GStreamer 1.0 port of video thumbnailing
Revision history for this message
Michal Hruby (mhr3) wrote : Re: GStreamer 1.0 port of video thumbnailing

Note that there's video thumbnailer in the SDK now, it uses image://thumbnailer/[file_path] for now (so for example "image://thumbnailer//home/phablet/Videos/foo.mp4").

Revision history for this message
Melanie Klotz (melanieklotz) wrote :

Not able to access pictures becsuse of sd card dismount pics disappears

Changed in gallery-app (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

What's the progress here? gallery-app is one of the few remaining packages that is holding back libav9 transition. In particular gstreamer0.10-ffmpeg dependency must be drop, the upgrade path is to depend on gstreamer1.0-libav instead.

Changed in gallery-app (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Jim Hodapp (jhodapp) wrote :

No progress here yet, I am targeting for this cycle but I have some higher priority bug fixes to work on first.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

Reassigning. This has a high priority in order to clean up trusty package versions these apps depend on.
Work is really to switch to use libthumbnailer.

no longer affects: touch-preview-images
Changed in gallery-app (Ubuntu):
assignee: Jim Hodapp (jhodapp) → Ugo Riboni (uriboni)
Changed in gallery-app:
assignee: Jim Hodapp (jhodapp) → Ugo Riboni (uriboni)
Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

libthumbnailer does not support retrieve a image from a specific position. This need to be implemented on libthumbnailer first.

Revision history for this message
Bill Filler (bfiller) wrote :

The work item here is to use the Thumbnailer ImageProvider from the Ubuntu SDK which should abstract any gstreamer code that is used by the gallery app for thumbnailing.

summary: - GStreamer 1.0 port of video thumbnailing
+ use libthumbnailer for gallery thumbnails
Ugo Riboni (uriboni)
Changed in gallery-app:
status: Confirmed → In Progress
Revision history for this message
Ugo Riboni (uriboni) wrote :

Using the thumbnailer from the SDK is a relatively painless process as far as the photo view and events view are concerned (a branch implementing this is linked to this bug).

However the album view makes use of a special thumbnail size (360) which is bigger than the large thumbnail size that the SDK thumbnailer can generate (256).

Scaling up the thumbnails isn't an option due to very noticeable loss of quality.

The only possibly solutions seem to be either altering the UI to use the smaller thumbnail size, or altering the SDK thumbnailer to be able to generate this new larger size.
The first option requires design input, the second option will make the SDK thumbnailer non-confroming with respect to the Freedesktop thumbnailing standard, which it has been following up until now.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thumbnailer - 1.0+14.04.20140304-0ubuntu1

---------------
thumbnailer (1.0+14.04.20140304-0ubuntu1) trusty; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Ugo Riboni ]
  * Add a new nonstandard thumbnail size (360) needed by gallery-app To
    test from QML you will need this MR as well:
    https://code.launchpad.net/~amanzi-team/ubuntu-ui-toolkit/ubuntu-ui-
    toolkit-xlarge-thumbnails/+merge/207500 (LP: #1221968)

  [ Jussi Pakkanen ]
  * Error condition checking and error messages.
  * Fix image orientation.
 -- Ubuntu daily release <email address hidden> Tue, 04 Mar 2014 10:09:12 +0000

Changed in thumbnailer (Ubuntu):
status: New → Fix Released
Bill Filler (bfiller)
Changed in gallery-app (Ubuntu):
status: In Progress → Fix Committed
Changed in gallery-app:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+14.04.20140319-0ubuntu1

---------------
gallery-app (0.0.67+14.04.20140319-0ubuntu1) trusty; urgency=low

  [ Barry Warsaw ]
  * Use pkg_resources API to retrieve sample_dir.

  [ Ugo Riboni ]
  * multiple gallery-app bug fixes Bug #907870: [desktop] Gallery does
    not display photos in sub folders, Bug #1221968: use libthumbnailer
    for gallery thumbnails, Bug #1268748: videos are not displayed when
    running on desktop, Bug #1271327: disable switching between camera
    and gallery on desktop, Bug #1287272: Black flash at the end of the
    zoom animation" (LP: #1221968, #1287272, #1268748, #907870,
    #1271327)

  [ Arthur Mello ]
  * multiple gallery-app bug fixes Bug #907870: [desktop] Gallery does
    not display photos in sub folders, Bug #1221968: use libthumbnailer
    for gallery thumbnails, Bug #1268748: videos are not displayed when
    running on desktop, Bug #1271327: disable switching between camera
    and gallery on desktop, Bug #1287272: Black flash at the end of the
    zoom animation" (LP: #1221968, #1287272, #1268748, #907870,
    #1271327)

  [ Bill Filler ]
  * updated framework version
  * multiple gallery-app bug fixes Bug #907870: [desktop] Gallery does
    not display photos in sub folders, Bug #1221968: use libthumbnailer
    for gallery thumbnails, Bug #1268748: videos are not displayed when
    running on desktop, Bug #1271327: disable switching between camera
    and gallery on desktop, Bug #1287272: Black flash at the end of the
    zoom animation" (LP: #1221968, #1287272, #1268748, #907870,
    #1271327)
  * fix blurry thumbnails when navigating photos

  [ CI bot ]
  * Resync trunk

  [ Sergio Schvezov ]
  * Fixing click launching

  [ Dimitri John Ledkov ]
  * Use pkg_resources API to retrieve sample_dir.
 -- Ubuntu daily release <email address hidden> Wed, 19 Mar 2014 20:20:32 +0000

Changed in gallery-app (Ubuntu):
status: Fix Committed → Fix Released
Bill Filler (bfiller)
Changed in gallery-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers