remove usage of qtdeclarative5-hud1.0

Bug #1221344 reported by Antti Kaijanmäki
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Dropping Letters
Fix Released
Undecided
Sergio Schvezov
camera-app
Fix Released
Undecided
Ugo Riboni
gallery-app
Fix Released
Undecided
Ugo Riboni
mediaplayer-app
Fix Released
Undecided
Ugo Riboni
notes-app
Fix Released
Undecided
Ugo Riboni
phone-app
Invalid
Undecided
Unassigned
share-app
Won't Fix
High
Ugo Riboni
webapps-demo
Fix Released
Undecided
Ugo Riboni
webbrowser-app
Fix Released
Undecided
Olivier Tilloy
camera-app (Ubuntu)
Fix Released
Undecided
Unassigned
gallery-app (Ubuntu)
Fix Released
Undecided
Unassigned
mediaplayer-app (Ubuntu)
Fix Released
Undecided
Unassigned
notes-app (Ubuntu)
Fix Released
Undecided
Unassigned
webbrowser-app (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

qtdeclarative5-hud1.0 (import Ubuntu.HUD 1.0) has been obsoleted by Unity Action API which is integrated with UITK MainView.

UITK MainView and Page components interfere with the Ubuntu.HUD and they can not co-exist without breaking the HUD search features.

Applications that are not using UITK.MainView must switch to using Unity Action API directly (import Ubuntu.Unity.Action 1.0)

Applications using UITK can just drop the dependency to qtdeclarative5-hud1.0 if they already depend on qtdeclarative5-ubuntu-ui-toolkit-plugin.

Applications not depending on UITK must drop the dependency to qtdeclarative5-hud1.0 and depend on qtdeclarative5-unity-action-plugin instead.

--

After all packages have dropped the dependency to qtdeclarative5-hud1.0 the package should be dropped from touch-preview-images.

Related branches

description: updated
description: updated
Revision history for this message
Olivier Tilloy (osomon) wrote :

This was already fixed in the browser app more than a month ago (rev. 238 of lp:webbrowser-app).

Changed in webbrowser-app:
assignee: nobody → Olivier Tilloy (osomon)
status: New → Fix Released
description: updated
Revision history for this message
Antti Kaijanmäki (kaijanmaki) wrote :

olivier:
$ apt-cache show webbrowser-app
Version: 0.22+13.10.20130903.3-0ubuntu1
Depends: qtdeclarative5-hud1.0

Changed in webbrowser-app:
status: Fix Released → Triaged
Bill Filler (bfiller)
Changed in camera-app:
assignee: nobody → Ugo Riboni (uriboni)
Changed in gallery-app:
assignee: nobody → Ugo Riboni (uriboni)
Changed in mediaplayer-app:
assignee: nobody → Ugo Riboni (uriboni)
Changed in notes-app:
assignee: nobody → Ugo Riboni (uriboni)
Changed in webbrowser-app:
assignee: Olivier Tilloy (osomon) → Ugo Riboni (uriboni)
Changed in webapps-demo:
assignee: nobody → Ugo Riboni (uriboni)
Revision history for this message
Olivier Tilloy (osomon) wrote :

Ooops… the dependency has crept back in at revision 242 by accident.
Fixing this is just a matter of removing the dependency from debian/control, there’s no actual runtime dependency in the code itself.

Changed in webbrowser-app:
assignee: Ugo Riboni (uriboni) → Olivier Tilloy (osomon)
status: Triaged → In Progress
Ugo Riboni (uriboni)
Changed in camera-app:
status: New → In Progress
Changed in gallery-app:
status: New → In Progress
Changed in mediaplayer-app:
status: New → In Progress
Ugo Riboni (uriboni)
Changed in notes-app:
status: New → In Progress
Revision history for this message
Ugo Riboni (uriboni) wrote :

This application does not use the hud

Changed in phone-app:
status: New → Invalid
Ugo Riboni (uriboni)
Changed in webapps-demo:
status: New → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:camera-app at revision None, scheduled for release in camera-app, milestone ubuntu-13.05

Changed in camera-app:
status: In Progress → Fix Committed
Ugo Riboni (uriboni)
Changed in share-app:
status: New → Invalid
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:notes-app at revision None, scheduled for release in notes-app, milestone ubuntu-13.04-month-5

Changed in notes-app:
status: In Progress → Fix Committed
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webapps-demo at revision 25, scheduled for release in webapps-demo, milestone Unknown

Changed in webapps-demo:
status: In Progress → Fix Committed
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mediaplayer-app at revision 134, scheduled for release in mediaplayer-app, milestone ubuntu-13.04-month-5

Changed in mediaplayer-app:
status: In Progress → Fix Committed
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webbrowser-app at revision 306, scheduled for release in webbrowser-app, milestone ubuntu-13.04-month-5

Changed in webbrowser-app:
status: In Progress → Fix Committed
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:gallery-app at revision 839, scheduled for release in gallery-app, milestone ubuntu-13.04-month-5

Changed in gallery-app:
status: In Progress → Fix Committed
no longer affects: touch-preview-images
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in camera-app (Ubuntu):
status: New → Confirmed
Changed in gallery-app (Ubuntu):
status: New → Confirmed
Changed in mediaplayer-app (Ubuntu):
status: New → Confirmed
Changed in notes-app (Ubuntu):
status: New → Confirmed
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+13.10.20130918.1-0ubuntu1

---------------
gallery-app (0.0.67+13.10.20130918.1-0ubuntu1) saucy; urgency=low

  [ Gerry Boland ]
  * Application module name changed, update the
    UbuntuApplicationWrapper.

  [ Ugo Riboni ]
  * Use the Actions API instead of using the HUD directly. (LP:
    #1221344, #1220279)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 839
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 08:02:09 +0000

Changed in gallery-app (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notes-app - 1.4+13.10.20130918.1-0ubuntu1

---------------
notes-app (1.4+13.10.20130918.1-0ubuntu1) saucy; urgency=low

  [ Ugo Riboni ]
  * Remove dependency on the hud, as it's not used anymore. (LP:
    #1221344)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 183
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 08:01:58 +0000

Changed in notes-app (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.22+13.10.20130918.1-0ubuntu1

---------------
webbrowser-app (0.22+13.10.20130918.1-0ubuntu1) saucy; urgency=low

  [ Alexandre Abreu ]
  * chrome selection.
  * Navigation support. (LP: #1187917)
  * Handle window raise event from webapps. The event might be occur for
    example when the app is being raised from the messaging menu etc.
    And additional proxy object is used to give access from the qml
    browser back to the native window object.
  * Add a command line argument for webapps that allows one to specify
    the root path for installed webapp searches. The uses cases are
    multiple, among other things local testing, and click packages
    (where webapps are installed in /opt/) and should be looked up
    there. For click webapps, the desktop-click hook will set the CWD
    when starting the app to the local click app folder and aa_exec will
    make sure that all is properly setup. Given the containment rules
    for click apps, the webbrowser-app should be told where to look for
    the webapp content (javascript snippet) and not follow the usual
    desktop rules (and the Exec line from the webapp desktop file should
    explicitly specify where to look for it based on CWD). .
  * Tweak title to remove the ubuntu browser references when run as a
    webapp.

  [ daker ]
  * Added support for IP adresses. (LP: #1166063)

  [ Olivier Tilloy ]
  * Temporarily skip a test that consistently fails on devices. This is
    to unblock autolanding of a large number of valid merge requests
    that have been sitting there for too long.
  * Remove unused runtime dependency on qtdeclarative5-hud1.0. It had
    crept back in by accident at revision 242. (LP: #1221344)
  * Skip a test that is flaky (for a known reason) on slow
    configurations.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 312
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 08:02:09 +0000

Changed in webbrowser-app (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediaplayer-app - 0.20.5+13.10.20130918.1-0ubuntu1

---------------
mediaplayer-app (0.20.5+13.10.20130918.1-0ubuntu1) saucy; urgency=low

  [ Ugo Riboni ]
  * Use the new actions API instead of passing actions directly to the
    HUD. (LP: #1221344)

  [ Omer Akram ]
  * Use the new actions API instead of passing actions directly to the
    HUD. (LP: #1221344)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 135
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 08:00:30 +0000

Changed in mediaplayer-app (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 2.9.1+13.10.20130919.2-0ubuntu1

---------------
camera-app (2.9.1+13.10.20130919.2-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Fix the infographic display, so that it correctly sets the minimum
    value.

  [ Ugo Riboni ]
  * Use the new actions API to add actions to the HUD, and make sure
    they actually do something. (LP: #1221344)

  [ Timo Jyrinki ]
  * Add qtdeclarative5-unity-action-plugin dependency

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 193
 -- Ubuntu daily release <email address hidden> Thu, 19 Sep 2013 09:01:53 +0000

Changed in camera-app (Ubuntu):
status: Confirmed → Fix Released
Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Fix Committed → Fix Released
Changed in gallery-app:
status: Fix Committed → Fix Released
Olivier Tilloy (osomon)
Changed in notes-app:
status: Fix Committed → Fix Released
David Barth (dbarth)
Changed in webapps-demo:
status: Fix Committed → Fix Released
Revision history for this message
Antti Kaijanmäki (kaijanmaki) wrote :

$ apt-cache rdepends qtdeclarative5-hud1.0
qtdeclarative5-hud1.0
Reverse Depends:
  dropping-letters
  share-app

Revision history for this message
Antti Kaijanmäki (kaijanmaki) wrote :

share-app still has a dependency.

Changed in share-app:
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → High
status: Invalid → Confirmed
Revision history for this message
Sergio Schvezov (sergiusens) wrote :

this is supposed to be unseeded

Changed in share-app:
status: Confirmed → Won't Fix
Changed in dropping-letters:
status: New → Fix Committed
assignee: nobody → Sergio Schvezov (sergiusens)
Changed in dropping-letters:
status: Fix Committed → Fix Released
Olivier Tilloy (osomon)
Changed in mediaplayer-app:
status: Fix Committed → Fix Released
Changed in camera-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers