Galera crash on gcache.page. file creation when disk space filled

Bug #1488535 reported by Przemek on 2015-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Galera
Undecided
Unassigned
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Fix Released
Undecided
Unassigned

Bug Description

This is copy of https://github.com/codership/galera/issues/324

When disk space gets filled with gcache.page files, Galera crashes on next page file creation attempt with:

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x35)[0x8fd375]
/usr/sbin/mysqld(handle_fatal_signal+0x4b4)[0x666264]
/lib64/libpthread.so.0(+0xf790)[0x7fc1a62be790]
/lib64/libc.so.6(memcpy+0x314)[0x7fc1a475ba24]
/usr/lib64/libgalera_smm.so(_Z22gcs_defrag_handle_fragP10gcs_defragPK12gcs_act_fragP7gcs_actb+0x120)[0x7fc185064cd0]
/usr/lib64/libgalera_smm.so(_Z13gcs_core_recvP8gcs_coreP12gcs_act_rcvdx+0x4e7)[0x7fc18506b4f7]
/usr/lib64/libgalera_smm.so(+0x17c748)[0x7fc185072748]
/lib64/libpthread.so.0(+0x7a51)[0x7fc1a62b6a51]
/lib64/libc.so.6(clone+0x6d)[0x7fc1a47ba9ad]

Confirmed on PXC 5.6.24 and Galera 3.11

Changed in percona-xtradb-cluster:
milestone: none → 5.6.25-25.12
status: New → Fix Committed
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released

This bug is not fixed. A PXC with 5.6.29 crashed after filling up the disk space with gcache files:

2016-08-25 02:58:08 19036 [Note] WSREP: Created page /mysql/mydata/db_data/gcache.page.000362 of size 134217728 bytes
2016-08-25 03:21:46 19036 [Note] WSREP: Created page /mysql/mydata/db_data/gcache.page.000363 of size 134217728 bytes
2016-08-25 03:45:57 19036 [Note] WSREP: Created page /mysql/mydata/db_data/gcache.page.000364 of size 134217728 bytes
01:52:04 UTC - mysqld got signal 7 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.
Please help us make Percona XtraDB Cluster better by reporting any
bugs at https://bugs.launchpad.net/percona-xtradb-cluster

key_buffer_size=134217728
read_buffer_size=2097152
max_used_connections=68
max_threads=502
thread_count=9
connection_count=4
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 2194485 K bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x35)[0x907585]
/usr/sbin/mysqld(handle_fatal_signal+0x4b4)[0x66b804]
/lib64/libpthread.so.0[0x3626a0f7e0]
/lib64/libc.so.6(memcpy+0x10e)[0x36266897ae]
/usr/lib64/libgalera_smm.so(_Z22gcs_defrag_handle_fragP10gcs_defragPK12gcs_act_fragP7gcs_actb+0x123)[0x7f1193d2d273]
/usr/lib64/libgalera_smm.so(_Z13gcs_core_recvP8gcs_coreP12gcs_act_rcvdx+0x4bb)[0x7f1193d336eb]
/usr/lib64/libgalera_smm.so(+0x17dfb0)[0x7f1193d3afb0]
/lib64/libpthread.so.0[0x3626a07aa1]
/lib64/libc.so.6(clone+0x6d)[0x36266e893d]
You may download the Percona XtraDB Cluster operations manual by visiting
http://www.percona.com/software/percona-xtradb-cluster/. You may find information
in the manual which will help you identify the cause of the crash.

Changed in percona-xtradb-cluster:
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Roel Van de Paar (roel11) wrote :

@Miguel please log new bug and post link here

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1845

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers