failed to build on sles 11 sp2

Reported by Fernando Ribeiro on 2012-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Galera
Undecided
Unassigned

Bug Description

Hi all,

After trying to build galera-23.2.2rc2 from source on Suse Linux Entreprise Server 11 SP2 I get various errors because scons can not put same libs like ldl lboost_filesystem lssl lcrypto on the arguments.

After changes on scons constructors (attached) Its build fine.

Please review and release this patch.

Best regards.

Alex Yurchenko (ayurchen) wrote :

Hi Fernando, which scons version do you have there?

Fernando Ribeiro (ipsec) wrote :

Hi Alex,

I'm running scons 2.2.0

# scons -v
SCons by Steven Knight et al.:
 script: v2.2.0.issue-2856:2676:d23b7a2f45e8[MODIFIED], 2012/08/05 15:38:28, by garyo on oberbrunner-dev
 engine: v2.2.0.issue-2856:2676:d23b7a2f45e8[MODIFIED], 2012/08/05 15:38:28, by garyo on oberbrunner-dev
 engine path: ['/usr/lib/scons/SCons']

I look now the gcc requirement is 4.4. In the sles 11 sp2 I've the version 4.3. However compile in 4.3 now works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers