Gala crashes if it doesn't find an input-source

Bug #1592859 reported by Davide Aguiari on 2016-06-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
High
Rico Tzschichholz

Bug Description

I installed Loki beta today and there were some little problems.
1) Custom partition: the windows was stuck on top left corner
2) Outline custom partition dialog had not borders.
3) I couldn't extend setup/terminal console

HP Omen 15
Nvidia GeForce GTX 860M

Related branches

Davide Aguiari (gorghino) wrote :
Davide Aguiari (gorghino) wrote :
Daniel Fore (danrabbit) wrote :

Oops I commented on the wrong report, my bad >.<

I can confirm this. Looks like we're not getting a compositor when choosing "Install", only when going the "Try" route

Changed in elementaryos:
status: New → Confirmed
milestone: none → loki-rc1
summary: - Elementary loki setup gui problems
+ No Compositor when Installing

Rico gave me a patch that fixes it

affects: elementaryos → gala
Changed in gala:
assignee: nobody → Cody Garver (codygarver)
importance: Undecided → High
milestone: loki-rc1 → none
status: Confirmed → In Progress
assignee: Cody Garver (codygarver) → nobody
milestone: none → loki-rc1
Cody Garver (codygarver) on 2016-06-16
summary: - No Compositor when Installing
+ Gala crashes if it doesn't find a keyboard layout
Cody Garver (codygarver) on 2016-06-16
summary: - Gala crashes if it doesn't find a keyboard layout
+ Gala crashes if it doesn't find an input-source
Changed in gala:
status: In Progress → Fix Committed
assignee: nobody → Rico Tzschichholz (ricotz)
Cody Garver (codygarver) on 2016-07-13
Changed in gala:
milestone: loki-rc1 → loki-beta2
Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers