Don't close empty workspace until after I've navigated away. [$25]

Bug #1232438 reported by David Gomes on 2013-09-28
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Medium
Unassigned

Bug Description

Much like bug 1070943, I think closing the last window on the last workspace shouldn't move me to the workspace to the left.

Why? A variety of reasons about my workflow, but a new reason has come up to me lately and maybe other daily users. What happens is that Gala SEGFAULTs way too many times when I close the last window on the last workspace. Attached is a patch that fixed it for me.

I can't fix the SEGFAULT but this not only improves my workflow as it also fixes a very nasty bug. Sure, Gala is on Cerbere for me so what happens is that it restarts but it takes a couple of seconds and I dislike the delay. For people who don't have it on Cerbere, they have to find a way to open a terminal (which is hard without Gala) and type in "gala --replace".

Anyway, another idea if the designers disagree with the previous one would be to have an option for this (no, I don't mean static workspaces which I haven't been using to get the vanilla experience and dogfood it against my own preferences), but something like when dynamic workspaces are activated, should Gala move to the workspace to the left when last window on last workspace is closed? I can code that :>.

Related branches

David Gomes (davidgomes) wrote :
Daniel Fore (danrabbit) wrote :

It's not supposed to just move to the workspace on the left. It's supposed to go the the previous workspace (left, right, #5, whatever).

The reason is that we only ever have 1 blank workspace at a time. Gala cleans up as you are working so that you don't have a bunch of empty workspaces.

Maarten Verwijs (x-contact-0) wrote :

Gala assumes that by closing the last windows on a workspace, I am finished
working on that workspace. Often, this is not the case.

I'd love it if there was an option to have Gala not switch away to
any other workspace, merely because I've happened to have closed the last
window.

Daniel Fore (danrabbit) wrote :

Maybe since we've received so much feedback about this feature we should change it such that Gala closes the workspace after you've moved away from it instead of when it's empty.

Cody Garver (codygarver) on 2013-12-07
Changed in gala:
milestone: none → isis-beta1
Daniel Fore (danrabbit) on 2013-12-07
Changed in gala:
status: New → Confirmed
summary: - Closing the last window on the last workspace
+ don't close empty workspace until after I've navigated away
Cody Garver (codygarver) on 2014-02-06
Changed in gala:
importance: Undecided → Medium
summary: - don't close empty workspace until after I've navigated away
+ don't close empty workspace until after I've navigated away [$15]
Changed in gala:
assignee: nobody → KJ Lawrence (kjtehprogrammer)
status: Confirmed → In Progress
Changed in gala:
status: In Progress → Confirmed
assignee: KJ Lawrence (kjtehprogrammer) → nobody
summary: - don't close empty workspace until after I've navigated away [$15]
+ Don't close empty workspace until after I've navigated away. [$25]
Avi Romanoff (aroman) wrote :

Uh, isn't this already implemented...? I just tested and it does this for me right now in Isis.

Isaac Parris (dexcasul) wrote :

It doesn't work for me on Isis. Fully updated.

There doesn't seem to be a commit for it, and the code still looks the same. I will take a look and fix it if it hasn't yet.

Changed in gala:
assignee: nobody → Isaac Parris (dexcasul)
Avi Romanoff (aroman) wrote :

oh yeah nevermind, misread the bug report.

Tom Beckmann (tombeckmann) wrote :

We'll get this fixed with the new multitaskingview branch. The workspace management part will be removed from the current workspaceview component and put into its own service.

tags: added: fixed-with-multitaskingview
Isaac Parris (dexcasul) wrote :

Updated.

Changed in gala:
assignee: Isaac Parris (dexcasul) → nobody
Cody Garver (codygarver) on 2014-05-27
Changed in gala:
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2014-07-18
Changed in gala:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2014-12-29
Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers