While using Alt-Tab switcher context is lost

Bug #1139953 reported by Pedro on 2013-03-02
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Medium
Tom Beckmann

Bug Description

The Alt-Tab Switcher in Elementary looks nice, but it is difficult to use, because only one window is shown while switching apps. The context is lost. The only way of seeing all available apps to switch through is in the dock, but I don't think that's enough. Especially in multi-monitor systems, when trying to quickly switch to another app, I often have to cycle several times through all apps before I manage to find the correct one. This is because the dock is relatively small, and only visible on one monitor. Also, looking at the dock to see all available apps to switch through is a focus killer.

Solution:
instead of displaying only one app with full opacity, and the rest invisible, keep also the non-focused apps visible, but slightly faded, just like the apps appear in the dock.

Tags: ui Edit Tag help

Related branches

Pedro (bx0-web-zwn) on 2013-03-02
description: updated
Cody Garver (codygarver) on 2013-03-02
affects: elementaryos → gala
Changed in gala:
status: New → Confirmed
Changed in gala:
status: Confirmed → In Progress
assignee: nobody → Tom Beckmann (tombeckmann)
RabbitBot (rabbitbot-a) on 2014-04-19
Changed in gala:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2014-04-19
Changed in gala:
importance: Undecided → Medium
milestone: none → isis-beta1
Daniel Fore (danrabbit) on 2014-12-29
Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers