Update Manager causes crash SIGSEGV in g_str_has_prefix()

Bug #1029609 reported by Pranav on 2012-07-26
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Medium
Unassigned

Bug Description

I have been using the daily build for quite a while now and I like to get the recent updates as soon as they are available.
Problem is whenever I run "sudo apt-get update" in the terminal, the update manager is launched and during this time, it looks like gala crashes for a second and restarts.
This doesn't happen if there is no update available.

Cody Garver (codygarver) wrote :

This has been happening to me too lately.

Changed in gala:
status: New → Confirmed
milestone: none → luna-beta1
Pranav (pranavkaranjkar) wrote :

Here is a video of the behaviour

Pranav (pranavkaranjkar) wrote :

I dont understand how these bugs are related

Accidentially duped the wrong bug. Sorry. Thanks for pointing out!

Changed in gala:
importance: Undecided → Medium
Cody Garver (codygarver) on 2012-08-12
summary: - gala crashes when update manager starts
+ Update Manager causes crash SIGSEGV in g_str_has_prefix()

Debug info from Apport is available in bug 1035897

Tom Beckmann (tombeckmann) wrote :

Can you try to reproduce this from rev205?

Changed in gala:
status: Confirmed → Incomplete
Daniel Fore (danrabbit) on 2012-09-01
Changed in gala:
milestone: luna-beta1 → none
Pranav (pranavkaranjkar) wrote :

This seems to be fixed in the daily build now

Changed in gala:
status: Incomplete → Fix Committed
Daniel Fore (danrabbit) on 2012-11-10
Changed in gala:
milestone: none → 0.1
Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers