Crashed hard with (gala:4714): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly created GLX context

Bug #1022094 reported by Andre Luis dos Santos on 2012-07-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Critical
Unassigned

Bug Description

Hi there!

I'm using a Ubuntu 12.04 install with the elementary-daily ppa. Pantheon is my default session, and gala the default window manager.

3 days ago, on a normal update from the elementary ppa, I've got a good crash in my system: all the windows lose the top bar (the one with window title, maximize and close), the plank (the elementary's default dock) and wingpanel are all messed up, with a great black retangle around they.

When I try to use gala --replace, the terminal dumps this:

(gala:4714): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly created GLX context
Erro do gerenciador de janelas: Unable to initialize Clutter.

The "Erro do gerenciador de janelas" means "Window Manager Error" in Portuguese (my system's default language).

I dunno what to do, received another update today, but the crash remains. All my windows are without borders and controllers (close, maximize, etc.), I can't use Alt+Tab to change between them, and the session is unusable.

Tried to "compiz --replace" but got a lot of errors and no changes.

Also, when I go to Unity (bah!) session, the desktop works normally, with compiz as the default WM, so I think the problem is not with my driver... Both 3D and 2D Unity sessions work.

====

My PC:
Intel Pentium D, 3GB RAM DDR2, GeForce nVidia 7300 LE (with the proprietary drivers).

Ubuntu 12.04 (fully updated) 32 bits

====

I've attached my xorg config file.

Tom Beckmann (tombeckmann) wrote :

It looks so strange and has no borders because gala didnt start at all.
I guess it was introduced with the recently added updated snapshots of libmutter. Could you run "mutter --replace" to be sure?
We may have to redirect you to gnome's bugzilla here...

When I tried to "mutter --replace", ubuntu warned me I didn't had mutter installed. So I did an apt-get install mutter.

After installation, I run mutter --replace again:

andre@andre-ubuntu:~$ mutter --replace

(mutter:2901): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly created GLX context
Erro do gerenciador de janelas: Unable to initialize Clutter.

It's the same error I get with gala...

Please post output of "apt-cache policy mutter" and "apt-cache policy gala" so we can tell if the problem is in Ubuntu's Mutter or in the Mutter to which we've cherrypicked upstream improvements.

andre@andre-ubuntu:~$ apt-cache policy mutter
mutter:
  Instalado: 3.4.1-0ubuntu99~elementary1
  Candidato: 3.4.1-0ubuntu99~elementary1
  Tabela de versão:
 *** 3.4.1-0ubuntu99~elementary1 0
        500 http://ppa.launchpad.net/elementary-os/daily/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     3.4.1-0ubuntu1 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
andre@andre-ubuntu:~$ apt-cache policy gala
gala:
  Instalado: 0.1-0~r127+pkg8~precise1
  Candidato: 0.1-0~r127+pkg8~precise1
  Tabela de versão:
 *** 0.1-0~r127+pkg8~precise1 0
        500 http://ppa.launchpad.net/elementary-os/daily/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
andre@andre-ubuntu:~$

Cool, it's the version with our cherrypicks. Thanks.

Daniel Fore (danrabbit) on 2012-07-21
Changed in gala:
milestone: none → luna-beta1
importance: Undecided → Critical

Same problem here. I can't use eOS. Tryed compiling the latest gala from bzr, but same thing.

Tom Beckmann (tombeckmann) wrote :

Can you try running gnome-shell?

I'll reinstall it using the latest x64 daily build. Then i'll try later today with gnome shell.

Well, i'm on it now. But i get some errors while trying to update Gala. It says gala depends on libmutter0-elementary2, but its caiming only the libmutter0-elementary1 is available. So it could not install Gala, and therefore i have can't start Pantheon-Session. Any ideas? using Luna (no ubuntu), and all the default's repos.

Tom Beckmann (tombeckmann) wrote :

This was actually fixed a bit ago. A apt-get update should (hopefully) do it.

Thanks Tom. Seems like it's fixed for me. System running fine with all the packages updated to last version. Gala installed and updated fine. Finally i can use my eOS again. Can't go back to other distros designs after had used eOS. You guys are awesome. Keep up the good work. ;]

Just a addendum: I have problem with the last update to the kernel (3.2.29). Keep getting Panics. They don't seem to happen with 3.2.27, so i'm sticking with it for some time. Seems to be a Ubuntu related problem, since you guys use it as base.

Tom Beckmann (tombeckmann) wrote :

That's a know and reported problem, unistalling ulatencyd will solve it.

I'm settings this bug to fixed now, as it seems to no longer happen, thanks for your help :)

Changed in gala:
status: New → Incomplete
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers